Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 29 Jan 2009 14:41:57 +0000
From:      Mark Knight <markk@knigma.org>
To:        freebsd-x11@freebsd.org
Subject:   Re: Xorg 7.4 breaks mga with G450
Message-ID:  <K+CJGqO1AcgJFwci@lap.knigma.org>
In-Reply-To: <1532XLOh3bgJFwKw@lap.knigma.org>
References:  <+$PUWxC8yOfJFwC1@lap.knigma.org> <1232939280.1973.7.camel@wombat.2hip.net> <alpine.BSF.2.00.0901260943380.1030@wonkity.com> <1233002689.88679.24.camel@squirrel.corp.cox.com> <alpine.BSF.2.00.0901261613410.2383@wonkity.com> <1233197046.1779.11.camel@wombat.2hip.net> <alpine.BSF.2.00.0901282132460.13788@wonkity.com> <UGsOoZHOCWgJFw9E@lap.knigma.org> <1233234690.1779.20.camel@wombat.2hip.net> <u5Jw3MNZdbgJFwIn@lap.knigma.org> <1233238588.1779.48.camel@wombat.2hip.net> <1532XLOh3bgJFwKw@lap.knigma.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
In message <1532XLOh3bgJFwKw@lap.knigma.org>, Mark Knight 
<markk@knigma.org> writes
>Well this might make you go "Ha":
>
>This next log is from the same hardware that I'm now having trouble 
>with Xorg 7.4.

Sorry to follow-up but looks like 7.4 is missing the chip rev and 
therefore seeing the device as a G400 rather than G450:

   (--) PCI:*(0@2:0:0) Matrox Graphics, Inc. MGA G400/G450 rev 0
   (--) MGA(0): Chipset: "mgag400" (G400)

the older driver has:

   (--) PCI:*(2:0:0) Matrox Graphics, Inc. MGA G400/G450 rev 130
   (--) MGA(0): Chipset: "mgag400" (G450)

Could this be it?


-- 
Mark A. R. Knight                               finger: markk@knigma.org
Tel: +44 7880 556751                            http://www.knigma.org/



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?K+CJGqO1AcgJFwci>