Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 11 Apr 2005 04:49:16 +0200
From:      "Daniel Eriksson" <daniel_k_eriksson@telia.com>
To:        "'FreeBSD Current'" <freebsd-current@freebsd.org>
Cc:        'Pawel Jakub Dawidek' <pjd@freebsd.org>
Subject:   ggate and mmap, possible problem?
Message-ID:  <!~!UENERkVCMDkAAQACAAAAAAAAAAAAAAAAABgAAAAAAAAA0VcX9IoJqUaXPS8MjT1PdsKAAAAQAAAAUjVS+OSdfk6HdP3/8g9ZQAEAAAAA@telia.com>

Next in thread | Raw E-Mail | Index | Archive | Help

Hi! Is it possible that there is some sort of problem using mmap on a (UFS2)
filesystem mounted over ggate?

I keep getting errors on the console when I enable mmap on a server running
a proprietary video server application (which is a binary compiled on FBSD
4.11 afaik). I don't have access to the source code for the server app
unfortunately (but I do have some access to the developers). I'm pretty sure
that with mmap enabled in the server, it tries to mmap all files smaller
than 50MB (most are 20-50MB).

The errors look like this:

g_vfs_done():ggate0[READ(offset=-1009882480640, length=65536)]error = 5
vnode_pager_getpages: I/O read error
vm_fault: pager read error, pid 1527 (mcvidserv)


This could certainly be a problem in the proprietary server, but I thought
I'd ask here too. This is on a recent 6-CURRENT system.

/Daniel Eriksson




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?!~!UENERkVCMDkAAQACAAAAAAAAAAAAAAAAABgAAAAAAAAA0VcX9IoJqUaXPS8MjT1PdsKAAAAQAAAAUjVS+OSdfk6HdP3/8g9ZQAEAAAAA>