Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 12 May 2020 00:43:35 +0530 (IST)
From:      Vishal Subramanyam <ekalavya.bsd@gmail.com>
To:        freebsd-questions@freebsd.org
Subject:   Cannot load intel driver(i915kms) without screen blanking out
Message-ID:  <alpine.BSF.2.22.395.2005120024590.1269@devMachine>

Next in thread | Raw E-Mail | Index | Archive | Help
I have a Intel Core i5-3320M processor with integrated graphics, FreeBSD 
12.1-RELEASE, GENERIC Kernel.
1) Had a fresh install of FreeBSD, tried using built-in i915kms driver 
present in /boot/kernel. Used kld_list in /etc/rc.conf to load the 
driver. Screen blanked out after a few lines during boot (presumably 
right after the point the driver was loaded, until then I was getting 
lots of boot messages as usual).
2) Installed drm-legacy-kmod, and used the driver file that it provided, 
i.e., /boot/modules/i915kms.ko. Same result as before.
3) Installed xorg-minimal. Executed startx command. Blank screen. Had to 
reboot (Ctrl-Alt-Bksp was suggested in some forums to return to tty, but 
didn't work).
4) Installed xorg. Installed xf86-video-intel. startx worked perfectly. 
Read the Xorg.0.log in /var/log/, seems intel driver was loaded and was 
used without any problems.
5) Tried to do a `kldload i915kms` in xterm, it said it had already been 
loaded into the kernel. This meant that xorg could load and use i915kms, 
but I possibly could only load it but not "use" it to view my tty.
6) Couldn't view other ttys using Ctrl-Alt-XX shortcut. When I tried to 
do so, the screen stayed the same but the windows in the window manager 
went out of focus.
7) I guessed that I did enter another terminal, but simply couldn't see 
the prompts. So I mentally assumed there was a login prompt and went 
ahead. I typed out my login stuff and pressed enter. Then I assumed 
there was a prompt infront of me and entered a command to start another 
xorg session. Note: Till now, I am still looking at the TWM xterm 
windows that are out of focus, not at a text console.
8) I execute startx infront of this mental virtual console. Voila. 
Another xorg session is started at ttyv10 (the original was at ttyv9), 
indicating that the terminal was there, but it simply wasn't visible and 
that I could switch to them by using Ctrl-Alt-XX.
What's happening? Why can't I use i915kms to view my tty? Why is xorg 
able to use it?
PS: When the screen goes blank while loading i915kms, I think its simple 
not able to display the tty's contents. So if I do my "mental" trick 
there and continue as if everything was there, will it work? I am going 
to try it now.




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.BSF.2.22.395.2005120024590.1269>