Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 7 Feb 2009 19:19:09 +0200
From:      Valentin Bud <valentin.bud@gmail.com>
To:        Giorgos Keramidas <keramida@ceid.upatras.gr>
Cc:        freebsd-questions <freebsd-questions@freebsd.org>
Subject:   Re: make installworld fails
Message-ID:  <139b44430902070919v6625a041j11a2ff48dc119dd6@mail.gmail.com>
In-Reply-To: <87mycyb4su.fsf@kobe.laptop>
References:  <139b44430902070752g17296e5cr6a910baa6c15386a@mail.gmail.com> <873aeqcjw5.fsf@kobe.laptop> <139b44430902070810n4215d90at777c824b94161a2d@mail.gmail.com> <87mycyb4su.fsf@kobe.laptop>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sat, Feb 7, 2009 at 6:16 PM, Giorgos Keramidas
<keramida@ceid.upatras.gr>wrote:

> On Sat, 7 Feb 2009 17:52:09 +0200, Valentin Bud <valentin.bud@gmail.com>
> wrote:
> > elo list,
> >
> > just updated a newly installed freebsd 7.1 system and it crashed here:
> >
> > ===> rescue (install)
> > ===> rescue/librescue (install)
> > ===> rescue/rescue (install)
> > install -s -o root -g wheel -m 555   rescue /rescue
> > install: rescue: No such file or directory
> > *** Error code 71
> >
> > Stop in /usr/src/rescue/rescue.
> > *** Error code 1
>
> On Sat, 7 Feb 2009 18:10:51 +0200, Valentin Bud <valentin.bud@gmail.com>
> wrote:
> > Hello,
> >
> > This are the parts from /etc/make.conf regarding system build options:
> > # --- system build options
> > WITHOUT_IPFILTER=yes
> > WITHOUT_IPX=yes
> > WITHOUT_LPR=yes
> > WITHOUT_RCMDS=yes
> > WITHOUT_SENDMAIL=yes
> >
> > I didn't give any arguments to
> > # make buildworld or
> > # make installworld
> >
> > I have ran them as i've typed them above.
> >
> > Is there something wrong in /etc/make.conf ?
>
> These options don't seem to affect the build of `/usr/src/rescue'.  Can
> you try running the build commands once more in that directory?
>
>    # cd /usr/src/rescue
>    # make cleandir ; make cleandir
>    # make obj depend all
>
> Then it should be possible to install the newly built /rescue binaries,
> and your installworld should complete fine.


Hello Giorgios,

Thanks that worked and the installworld succeeded. Is this a bug? Should i
report it?

thanks,
v



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?139b44430902070919v6625a041j11a2ff48dc119dd6>