Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 29 Jan 2009 12:13:31 -0500
From:      Robert Noland <rnoland@FreeBSD.org>
To:        Mark Knight <markk@knigma.org>
Cc:        freebsd-x11@freebsd.org
Subject:   Re: Xorg 7.4 breaks mga with G450
Message-ID:  <1233249211.1766.24.camel@wombat.2hip.net>
In-Reply-To: <IoupDdQEvdgJFwsM@lap.knigma.org>
References:  <+$PUWxC8yOfJFwC1@lap.knigma.org> <1232939280.1973.7.camel@wombat.2hip.net> <alpine.BSF.2.00.0901260943380.1030@wonkity.com> <1233002689.88679.24.camel@squirrel.corp.cox.com> <alpine.BSF.2.00.0901261613410.2383@wonkity.com> <1233197046.1779.11.camel@wombat.2hip.net> <alpine.BSF.2.00.0901282132460.13788@wonkity.com> <UGsOoZHOCWgJFw9E@lap.knigma.org> <1233234690.1779.20.camel@wombat.2hip.net> <u5Jw3MNZdbgJFwIn@lap.knigma.org> <1233238588.1779.48.camel@wombat.2hip.net> <1532XLOh3bgJFwKw@lap.knigma.org> <K+CJGqO1AcgJFwci@lap.knigma.org> <1233244386.1766.1.camel@wombat.2hip.net> <R$3fWbPhHdgJFwuz@lap.knigma.org> <X$TeWyPxLdgJFwvR@lap.knigma.org> <1233245396.1766.13.camel@wombat.2hip.net> <IoupDdQEvdgJFwsM@lap.knigma.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help

--=-U3o1e07uz0r8iVZAxO0u
Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

On Thu, 2009-01-29 at 16:39 +0000, Mark Knight wrote:
> In message <1233245396.1766.13.camel@wombat.2hip.net>, Robert Noland=20
> <rnoland@FreeBSD.org> writes
> >Ok, I'll try and have a look at the detection code... It's possible that
> >this is somehow related to the switch to libpciaccess.
>=20
> This patch fixes the problem for me in a horribly broken way:
>=20
> >mkn@shrewd$ pwd
> >/usr/ports/x11-drivers/xf86-video-mga/work/xf86-video-mga-1.9.100/src
> >mkn@shrewd$ sudo diff -u mga_driver.c.orig mga_driver.c
> >--- mga_driver.c.orig   2009-01-29 16:31:42.000000000 +0000
> >+++ mga_driver.c        2009-01-29 16:35:01.000000000 +0000
> >@@ -1473,8 +1473,7 @@
> >        xf86ErrorF("\n");
> >     }
> >
> >-    pMga->is_Gx50 =3D ((pMga->Chipset =3D=3D PCI_CHIP_MGAG400) &&=20
> >(pMga->ChipRev >=3D 0x80))
> >-       || (pMga->Chipset =3D=3D PCI_CHIP_MGAG550);
> >+    pMga->is_Gx50 =3D 1;
> >     pMga->is_G200SE =3D (pMga->Chipset =3D=3D PCI_CHIP_MGAG200_SE_A_PCI=
)
> >        || (pMga->Chipset =3D=3D PCI_CHIP_MGAG200_SE_B_PCI);
>=20
> So the cause is clear but finding the bug is way beyond me...

Hrm, very interesting... now I just have to figure out if it is
libpciaccess or the driver that is at fault.

robert.

> Cheers,

--=-U3o1e07uz0r8iVZAxO0u
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.10 (FreeBSD)

iEUEABECAAYFAkmB47sACgkQM4TrQ4qfROMxdACfWe3yeXmf8kjljrH1749WqVvV
HwMAl1DopPjVMBFfF65Nh2ZIQZ8Z5FY=
=5h+P
-----END PGP SIGNATURE-----

--=-U3o1e07uz0r8iVZAxO0u--




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?1233249211.1766.24.camel>