Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 05 Jan 2018 09:57:41 +0100
From:      Andreas Schneider <as@it64.ch>
To:        freebsd-questions@freebsd.org
Subject:   Data lost with zfs and bhyve
Message-ID:  <20180105095741.Horde.0RD_XU5kS0EfgsOwQrrpPrS@sync.jsa.ch>

Next in thread | Raw E-Mail | Index | Archive | Help
yesterday i had a strange data loss

here is my configuration

Freebsd 11.0p9 bhyve box (i know i should upgrade)

1x Guest with FreeBSD 10.3  file disk image (with ufs inside)
2x Guests with FreeBSD 11.1 zfs filesystems  on the same zpool  
(mirror) like first Guest
2x Guests with FreeBSD 11.0 zfs filesystems on other zpool other mirror
128 GB RAM ... HDs are SSD

Server freezes at 23:00 local time -> no login possible to bhyve box  
and the first guest... other guests running normal
On my fault i had no access to the KVM-Console with ipmi .. so i  
shtudown per ipmi acpi power key
After reboot the data on the first guest was reset to 16:25 local  
time... (no snapshots after this time)
the first guest is a imap server ... i know it was working until 21:30  
because a had some mail received between 19:00 to 21:30.. after reboot  
data is lost up to 16:24

i found the following in messages.log at the bhyve box:

Jan  4 16:25:04 hv1 kernel: pid 48842 (zfs), uid 0: exited on signal 6  
(core dumped)

an now my question ... how can i prevent such a sick behavior?



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20180105095741.Horde.0RD_XU5kS0EfgsOwQrrpPrS>