Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 19 Jan 2015 09:23:08 -0600
From:      "William A. Mahaffey III" <wam@hiwaay.net>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: Installing Sublime Text3 on FreeBSD-10.1-i386
Message-ID:  <54BD215C.3040506@hiwaay.net>
In-Reply-To: <alpine.BSF.2.11.1501191506110.1375@mail.fig.ol.no>
References:  <mailman.60.1421409601.72162.freebsd-questions@freebsd.org> <BLU436-SMTP220A1C5AFBDA897CC34F219F64F0@phx.gbl> <alpine.BSF.2.11.1501161358150.1375@mail.fig.ol.no> <BLU436-SMTP241E8B0E36F939AF55134ACF64A0@phx.gbl> <alpine.BSF.2.11.1501191506110.1375@mail.fig.ol.no>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 01/19/15 08:10, Trond Endrestøl wrote:
> On Mon, 19 Jan 2015 18:58+0530, Manish Jain wrote:
>
>> On 01/16/2015 18:31, Trond Endrestøl wrote:
>>> On Fri, 16 Jan 2015 18:03+0530, Manish Jain wrote:
>>>
>>>> Hi,
>>>>
>>>> Has anyone managed to fully port Sublime Text/Sublime Text3 to
>>>> FreeBSD-10.1-i386 ? Running st3 on my system gets me the famous
>>>> "GLIBC_2.11 not found" message.
>>> These two ports are not native to FreeBSD, but precompiled Linux
>>> executables, AFAICT.
>>>
>>> On my system, editors/sublime{,3} needs:
>>>
>>> emulators/linux_base-c6
>>> accessibility/linux-c6-atk
>>> graphics/linux-c6-cairo
>>> textproc/linux-c6-expat
>>> x11-fonts/linux-c6-fontconfig
>>> graphics/linux-c6-gdk-pixbuf2
>>> x11-toolkits/linux-c6-gtk2
>>> graphics/linux-c6-jpeg
>>> x11-toolkits/linux-c6-pango
>>> graphics/linux-c6-png
>>> graphics/linux-c6-tiff
>>> x11/linux-c6-xorg-libs
>>>
>>> Maybe you should check the condition of the "Linuxulator" ports
>>> installed on your system. The above list would be a good start.
>> Hi,
>>
>> I tried installing as per your advice. base-c6 asked me to remove base-f10
>> with 'pkg delete'. That done I installed all the ports in your list. Now
>> running 'make install' in sublime3 gives me Error Code 1 :
>>
>>> linux-sublime-3.0.65 depends on file: /compat/linux/etc/fedora-release - not
>>> found
>>> ===>    Verifying install for /compat/linux/etc/fedora-release in
>>> /usr/ports/emulators/linux_base-f10
>>>
>>> ===>  linux_base-f10-10_7 conflicts with installed package(s):
>>>        linux_base-c6-6.6
>>> They will not build together.
>> Thanks for any help.
> Hum. For some reason it wants the old Fedora stuff on your system, not
> the newer CentOS stuff as it wants on my system.
>
> Is your ports tree up to date?
>
> What's the contents of /etc/make.conf?
>

Could it be that the pkg in question needs to be told to use the 
linux-c6 compatibility stuff, not linux-f10 ? I have had issues on this 
front in the last 6-8 weeks. Mine eventually got resolved through no 
effort on my part (including messing around w/ ports tree) except for 
whining on-list .... It seems that some pkg's need to be told to use the 
newer linux-compatibility stuff ....

-- 

	William A. Mahaffey III

  ----------------------------------------------------------------------

	"The M1 Garand is without doubt the finest implement of war
	 ever devised by man."
                            -- Gen. George S. Patton Jr.




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?54BD215C.3040506>