Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 26 May 2020 17:48:02 +0100
From:      matthew@FreeBSD.org
To:        freebsd-questions@freebsd.org
Subject:   Re: nvi expandtab - tabs to spaces
Message-ID:  <bc251662-9588-6e2d-74c1-76df1829c214@infracaninophile.co.uk>
In-Reply-To: <CAEJNuHw4fWBUP6Htutrv7RywBkxRfr2o4cFo7v6e0UxNfjgoEQ@mail.gmail.com>
References:  <0c30ebf7-e5b1-6fcb-d81e-2a039415f8a1@chezmarcotte.ca> <CAEJNuHyDc+1hgg_UwDzuu=eskf-DhhoKU+juF3LUL+2qQ919HQ@mail.gmail.com> <c736fc5f-3a12-6d8a-1830-df44b74b2dfb@chezmarcotte.ca> <CAD1r1D+m+UQ=ECS=wCsKt5684buoE-LfnGqhy+iyxB=VdqiPfw@mail.gmail.com> <CAEJNuHw4fWBUP6Htutrv7RywBkxRfr2o4cFo7v6e0UxNfjgoEQ@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 26/05/2020 17:42, Ottavio Caruso via freebsd-questions wrote:
> On Tue, 26 May 2020 at 17:21, Einar Indridason <einar.indrida@gmail.com> wrote:
>>
>> On Tue, May 26, 2020 at 4:17 PM Derek (freebsd lists) <
>> 482254ac@razorfever.net> wrote:
>>
>>> On 2020-05-26 11:08 a.m., Ottavio Caruso via freebsd-questions wrote:
>>>> On Tue, 26 May 2020 at 14:48, Derek (freebsd lists)
>>>> <482254ac@razorfever.net> wrote:
>>>>> Is there any appetite (from committers) for a patch/import of the
>>>>> feature from OpenBSD?
>>>>
>>>> What version of vi is on OpenBSD 6.7? On my 6.6 [Version 1.79
>>>> (10/23/96)] the expandtab is not available, but on NetBSD 9.0 [Version
>>>> (1.81.6-2013-11-20nb4], it is.
>>>>
>>>> Be careful importing features from the 1.xx branch to the 2.x.x., the
>>>> one in FreeBSD.
>>>>
>>>
>>> Yeah, I'm not sure.  I'm not even going to start to bark up that tree,
>>> without some support.
>>>
>>> Thanks
>>>
>>
>> There is also 'vim' (and you could always do  :set compatible to make vim
>> behave more like vanilla vi)
> 
> Not the OP, but that is not good. Vim, with or without compatibility
> mode, will not behave exactly like vi. Apart from using vim, which is
> probably the best solution, an alternative would be having a port from
> a different nvi tree. The issue gets even more complicated by the fact
> that there are multiple vi forks and all of them are slightly
> incompatible with each other.
> 

Or use expand(1) from the command line...

	Cheers,

	Matthew




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?bc251662-9588-6e2d-74c1-76df1829c214>