Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 27 Feb 2012 22:53:00 +0000
From:      Matthew Seaman <m.seaman@infracaninophile.co.uk>
To:        freebsd-questions@freebsd.org
Subject:   Re: "find" not traversing all directories on a single zfs file system
Message-ID:  <4F4C094C.1010900@infracaninophile.co.uk>
In-Reply-To: <4F4BFB09.9090002@weogeo.com>
References:  <4F4BFB09.9090002@weogeo.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enigE0BD73882A3371C489855253
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

On 27/02/2012 21:52, Robert Banfield wrote:
> Long version:  I'm new to FreeBSD and ZFS (many years of linux
> experience though), so my apologies if I'm missing something
> straightforward here.  This is a tile server which has tens of millions=

> of mostly small files.  I'm logged in as root, and there is no networke=
d
> file system anywhere in the mix.  I'm using the version of find
> installed with FreeBSD 9.0-RELEASE amd64.
>=20
> cd /zfs_mount_point/mydir
> find . &> ../file_list
>=20
> I would presume that file_list contains a list of every file and
> directory inside of /zfs_mount_point/mydir, however some directories
> contain only the directory entry without any of the file and
> subdirectories it contains.

These are all actual directories -- no symbolic link or anything like
that?  I assume permissions are not the problem?  All directories have
at least mode r_x for your user id? (Hmmm... but you are logged in as
root -- can't be that then.)  How about ACLs?  Are you using those at
all on your filesystem?

The symptoms you are observing are definitely incorrect, and not at all
what the vast majority of find(1) users would experience.  Something is
definitely a bit fubar on your machine.  It would be useful to try and
establish if it is the find(1) program giving bogus results, or whether
it is some other part of the system.  Do other methods of printing out
the filesystem contents suffer from the same problem -- eg. 'ls -R .' or
'tar -cvf /dev/null .'  Is there anything in the system log or printed
on the console?  (Note: I always find it useful to enable the
console.log and all.log by uncommenting the relevant lines in
/etc/syslog.conf and following the other instructions there.)

Also, is this 9.0-RELEASE straight from the installation media, or did
you compile it yourself?  If you compiled it yourself, what compiler did
you use (gcc or clang)?  What optimization and what architecture
settings -- trying to tweak such things for maximum optimization
frequently leads to dissapointment.

If you installed onto ZFS, what procedure did you follow, given that
bsdinstall doesn't have that capability yet?  Was it by following one of
the well-known recipes like http://wiki.freebsd.org/RootOnZFS/GPTZFSBoot =
?

	Cheers,

	Matthew

--=20
Dr Matthew J Seaman MA, D.Phil.                   7 Priory Courtyard
                                                  Flat 3
PGP: http://www.infracaninophile.co.uk/pgpkey     Ramsgate
JID: matthew@infracaninophile.co.uk               Kent, CT11 9PW


--------------enigE0BD73882A3371C489855253
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG/MacGPG2 v2.0.16 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk9MCVUACgkQ8Mjk52CukIzPGgCfZSsXewibxHTchp4XQDT1b8oA
cPYAn01M7J5yTjA7SY3fATaSX4871JmC
=eUY7
-----END PGP SIGNATURE-----

--------------enigE0BD73882A3371C489855253--



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4F4C094C.1010900>