Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 26 Mar 2013 11:53:59 +1030
From:      Shane Ambler <FreeBSD@ShaneWare.Biz>
To:        Jim Ballantine <j.ballantine@gmail.com>,  FreeBSD-questions <freebsd-questions@freebsd.org>
Subject:   Re: security/heimdal generates openssl conflict [was - Re: Installing openssl from ports]
Message-ID:  <5150F8AF.5090403@ShaneWare.Biz>
In-Reply-To: <CADcmFMWu+AG_ySY+Mh0RdoAvTz7tkhfTEw6e=attG2fmwZ5whg@mail.gmail.com>
References:  <CADcmFMVc+1RUpkyoUXosV-S8RaBMhe7R8rLkBY4Gbnun+oXDKA@mail.gmail.com> <514C49FD.90700@ShaneWare.Biz> <CADcmFMUj_7qS4mbw2udJXJchyt4-8rStygAZfG-_KAGpRFs3gQ@mail.gmail.com> <514D6AFE.1030708@ShaneWare.Biz> <CADcmFMWu+AG_ySY+Mh0RdoAvTz7tkhfTEw6e=attG2fmwZ5whg@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 26/03/2013 00:42, Jim Ballantine wrote:
> Hi
>
> I had removed the port, but it was reinstalled as a dependency of
> other ports. I have WITH_OPENSSL_PORT=yes in /etc/make.conf, and
> after I do a pkg delete -f heimdal openssl installs fine, but when I
> try to install heimdal from ports (with  DISABLE_CONFLICTS=
> openssl-1.0.1_8 in the Makefile) the installs ends with:
>
<snip>
> Stop in /usr/ports/security/heimdal.
>
> So I must be doing something wrong, but what??
>

Your not doing anything wrong, that's why I cc'd the last email to the
heimdal maintainer. I might look at making a patch to fix it today and
submit a PR as it appears the maintainer didn't respond to a previous PR

 From what I see heimdal includes the openssl man pages in it's list of
files it installs, the new pkg system is picking up the same files
installed by openssl and heimdal and preventing the conflict, while the
old install system overlooked it.

Either the man pages list is incorrect or heimdal installs a duplicate
copy of the openssl man pages - maybe this could be disabled if openssl
from ports is used.




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?5150F8AF.5090403>