Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 16 Aug 2017 07:34:15 -0700
From:      Kurt Buff <kurt.buff@gmail.com>
To:        "freebsd-questions@freebsd.org" <freebsd-questions@freebsd.org>
Subject:   Re: FUBAR on an upgrade - need some help
Message-ID:  <CADy1Ce7dzHHd7uv3dBMYvqqUMTP=d3zRnVM__TEj6ZCHGWwBMA@mail.gmail.com>
In-Reply-To: <CALeGphzrYGaWPqH_RCHY21UQf4XM12K29JvmHTL2Ww2cyL9biw@mail.gmail.com>
References:  <CADy1Ce4Su5NDequMC3t10Suut6iSsw=zT0RK1h_GpRxnQQsFEQ@mail.gmail.com> <CALeGphzrYGaWPqH_RCHY21UQf4XM12K29JvmHTL2Ww2cyL9biw@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Thank you.

Kurt

On Wed, Aug 16, 2017 at 12:14 AM, Jack L. <xxjack12xx@gmail.com> wrote:
> boot into single user mode and then mount -rw / and then modify fstab
>
> On Tue, Aug 15, 2017 at 7:29 PM, Kurt Buff <kurt.buff@gmail.com> wrote:
>> I have an old Acer AspireOne netbook that's been running 10.1-RELEASE.
>>
>> Yesterday I upgraded it using freebsd-update to 10.2 and then to 10.3,
>> and it went fine.
>>
>> Then I upgraded it to 11.0-RELEASE, and it failed during boot, saying
>> it wanted to boot from ad4s1a, but couldn't find it.
>>
>> I have managed to get it into single user, and have run "df-h" and
>> "gpart show", which don't agree at all. Output:
>>
>> # df -h
>> Filesystem     Size     Used     Avail   Capacity   Mounted on
>> /dev/ad4s1a    140G   36G        93G        28%    /
>> devfs               1.0k    1.0k          0B      100%   /dev
>>
>> #gpart show
>> =>         63   312581745   ada0   MBR    (149GB)
>>              63   312581745        1   freebsd      [active]     (149GB
>>
>> =>           0   312581745   ada0s1    BSD     (149GB)
>>                0   8388608               2    freebsd-swap    (4.0GB)
>>     8388608    304193137           1    freebsd-ufs      (145GB)
>>
>> # cat /etc/fstab
>> # Device            Mountpoint      FStype     Options      Dump      Pass#
>> /dev/ad4s1b       none               swap         sw             0            0
>> /dev/ad4s1a       /                     ufs            rw
>> 1            1
>>
>>
>> I can't seem to use vi to modify fstab.
>>
>> I'm a bit lost on how to recover from this. Can anyone give me a clue?
>>
>> Thanks,
>>
>> Kurt
>> _______________________________________________
>> freebsd-questions@freebsd.org mailing list
>> https://lists.freebsd.org/mailman/listinfo/freebsd-questions
>> To unsubscribe, send any mail to "freebsd-questions-unsubscribe@freebsd.org"



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CADy1Ce7dzHHd7uv3dBMYvqqUMTP=d3zRnVM__TEj6ZCHGWwBMA>