Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 1 May 2018 17:58:28 +0100
From:      RW <rwmaillists@googlemail.com>
To:        freebsd-questions@freebsd.org
Subject:   Re: Upgrading 10.4 to 11.1
Message-ID:  <20180501175828.49a07cf8@gumby.homeunix.com>
In-Reply-To: <20180501001407.7752facafb7593fd6aa252c1@gmail.com>
References:  <5AE783D2.40004@webtent.org> <20180501001407.7752facafb7593fd6aa252c1@gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Tue, 1 May 2018 00:14:07 +0300
G=C3=B6k=C5=9Fin Akdeniz wrote:

> Mon, 30 Apr 2018 17:00:02 -0400 tarihinde
> Robert Fitzpatrick via freebsd-questions
> <freebsd-questions@freebsd.org> yazm=C4=B1=C5=9F:
>=20
> > root@dev:~ # portupgrade -a
> > [Reading data from pkg(8) ... - 150 packages found - done]
> > ** Port marked as IGNORE: www/apache24:
> >          Invalid perl5 version 5.18
> > ** Port marked as IGNORE: textproc/aspell:
> >          Invalid perl5 version 5.18
> > ...
> >=20
> > Getting the Invalid perl5 for all the packages, I tried doing pkg=20
> > upgrade perl5 and ended up adding /usr/local/bin/perl and the ports=20
> > still looking at perl5.18 in /usr/bin/perl. Have I done something
> > wrong or need to handle Perl separate first?
> >  =20
> Default PERL version changed. So you have to upgrade to default PERL
> version which is 5.26.=20

Aside from the perl problem, "portupgrade -a" probably wont work anyway
because portupgrade doesn't supports flavors



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20180501175828.49a07cf8>