Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 5 Jan 2015 15:02:20 +0100
From:      Polytropon <freebsd@edvax.de>
To:        Xavier Freebsd Questio <xavierfreebsdquestio@aim.com>
Cc:        Xavier Freebsd Questio via freebsd-questions <freebsd-questions@freebsd.org>
Subject:   Re: emulate a Xorg configuration of GNU/Linux (Fedora 21) on FreeBSD
Message-ID:  <20150105150220.cdc5e793.freebsd@edvax.de>
In-Reply-To: <8D1F66AE0047A1D-15D0-B871@webmail-vm170.sysops.aol.com>
References:  <8D1F641A1D2B4CB-15D0-A6C2@webmail-vm170.sysops.aol.com> <20150104153549.70c269ae.freebsd@edvax.de> <8D1F6518B6F7572-15D0-ABA6@webmail-vm170.sysops.aol.com> <20150104180240.6c6cf30b.freebsd@edvax.de> <8D1F65CB4E03AE5-15D0-B0B5@webmail-vm170.sysops.aol.com> <20150104190716.35660e63.freebsd@edvax.de> <8D1F66AE0047A1D-15D0-B871@webmail-vm170.sysops.aol.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sun, 4 Jan 2015 14:22:12 -0500, Xavier Freebsd Questio via freebsd-questions wrote:
> On Sun, Jan 04, 2015 at 07:07:16PM +0100, Polytropon wrote:
> > What GPU driver does X use on the Linux system?
> >
> 
> See Xorg log of GNU/Linux: http://pastebin.com/85Xym8Vs

This seems to be /var/log/messages, not /var/log/Xorg.0.log.

Within the line noise, I think I found something:

	(II) LoadModule: "vesa"
	(II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so

So this also uses VESA?

But the device detection seem to work:

	(II) modesetting(0): EDID for output LVDS-0
	(II) modesetting(0): Manufacturer: IVO  Model: 3f4  Serial#: 0

It lists several supported modes, but they somehow don't
really look like what one would associate with a modern
flat panel TV set...

Note this:

	(II) modesetting(0): Output VGA-0 connected
	(II) modesetting(0): Output LVDS-0 connected
	(II) modesetting(0): Output DVI-0 disconnected
	(II) modesetting(0): Output DisplayPort-0 disconnected

One probably is the internal display, the other one is
the TV. Both are claimed to be initialized at 800x600,
which sounds strange...

But DRI and GLX seem to be supported. Funny...

	(II) modesetting(0): EDID vendor "IVO", prod id 1012
	(II) modesetting(0): Printing DDC gathered Modelines:
	(II) modesetting(0): Modeline "1024x600"x0.0   [...]
	(II) modesetting(0): Allocate new frame buffer 1024x768 stride

It's quite hard to see the "normal run" of X.org messages
in this file, it seems to represent more than one session.

Does this file mean that Linux is successful by using the
VESA driver for that card and TV combination?



> > So your GPU wasn't properly detected. Are you sure it
> > is supported?
> >
> 
> In FreeBSD I don't know. I ask for it here.

It's basically about the availability of a X.org driver.
Maybe a kernel module is also involved.



> http://pastebin.com/ZBqSx4Sn

That is the relevant entry:

vgapci0@pci0:0:2:0:     class=0x030000 card=0x09331025 chip=0x0f318086 rev=0x0e hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'ValleyView Gen7'
    class      = display
    subclass   = VGA

Doesn't say much... I'm not sure which of the available
Intel driver supports a "ValleyView Gen7". Supported
cards (or chipsets) are usually listed in the manpage
after you've installed the driver ...



> http://pastebin.com/uC4ZqNyh

... which you have:

root@acer-jan:~ # pkg info | grep xf86-video-intel
xf86-video-intel-2.21.15_6     Driver for Intel integrated graphics chipsets

By the way: There's no need to paste two lines of text
to pastebin. Not everyone likes to utilize a web browser
when reading or answering e-mails, especially because
this often is a privacy concern.



> The load driver: http://pastebin.com/aKuxRbkg

Relevant lines:

[    73.161] (II) LoadModule: "intel"
[    73.167] (II) Loading /usr/local/lib/xorg/modules/drivers/intel_drv.so
[    73.183] (II) Module intel: vendor="X.Org Foundation"
[    73.183]    compiled for 1.14.7, module version = 2.21.15
[    73.183]    Module class: X.Org Video Driver
[    73.183]    ABI class: X.Org Video Driver, version 14.1
	[...]
[    73.186] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
        HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
        HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
        HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
        HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200

I don't see your particular card listed here, except of
course "ValleyView Gen7" is one of them.

Interestingly, VESA is _also_ loaded. Why is that?

For comparison, I have a nVidia card, and the nVidia
driver is loded. It's the only driver which is loaded.
It it possible that there are two distinct graphic
subparts in that laptop?



> More ideas ? Thanks.

What's the output of the "xrandr" command (without
any options)?



-- 
Polytropon
Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20150105150220.cdc5e793.freebsd>