Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 02 Feb 2009 16:55:53 +1000
From:      Warren Liddell <shinjii@maydias.com>
To:        freebsd-questions@freebsd.org
Subject:   Error compiling Imagmagick
Message-ID:  <498698F9.1030204@maydias.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Im running AMD64 4gig RAM FreeBSD 7.1-STABLE, ports an src are all up to 
date... Below is the error output trying to compile imagmagick as part 
of the dependency whilst installing DVDrip
=====================

cd PerlMagick && make CC='cc -std=gnu99' 
test                                                                                                                                    

/bin/sh ../magick.sh PERL_DL_NONLAZY=1 /usr/local/bin/perl5.8.9 
"-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 
'blib/arch')" t/*.t t/bzlib/*.t t/fpx/*.t t/jbig/*.t t/jpeg/*.t 
t/jp2/*.t t/png/*.t t/tiff/*.t t/x11/*.t 
t/zlib/*.t                                                                                                                   

t/blob............ok                                                                                                                                                             

t/bzlib/read......ok                                                                                                                                                             

t/bzlib/write.....ok                                                                                                                                                             

t/composite.......ok                                                                                                                                                             

t/filter..........ok                                                                                                                                                             

t/fpx/read........ok                                                                                                                                                             

t/fpx/write.......ok                                                                                                                                                             

t/getattribute....ok                                                                                                                                                             

t/jbig/read.......ok                                                                                                                                                             

t/jbig/write......ok                                                                                                                                                             

t/jp2/read........ok                                                                                                                                                             

t/jpeg/read.......ok                                                                                                                                                             

t/jpeg/write......ok                                                                                                                                                             

t/montage.........ok                                                                                                                                                             

t/png/read-16.....ok                                                                                                                                                             

t/png/read........ok
t/png/write-16....ok
t/png/write.......ok
t/read............ok
t/setattribute....ok
t/tiff/read.......ok
t/tiff/write......ok
t/write...........ok
t/x11/read........No protocol specified
t/x11/read........ok
t/x11/write.......No protocol specified
t/x11/write....... Failed 1/2 subtests
t/zlib/read.......ok
t/zlib/write......ok

Test Summary Report
-------------------
t/x11/write   (Wstat: 0 Tests: 2 Failed: 1)
  Failed test:  1
Files=27, Tests=345,  8 wallclock secs ( 0.32 usr  0.10 sys +  5.52 
cusr  1.16 csys =  7.09 CPU)
Result: FAIL
Failed 1/27 test programs. 1/345 subtests failed.
*** Error code 255

Stop in /usr/ports/graphics/ImageMagick/work/ImageMagick-6.4.8-3/PerlMagick.
*** Error code 1

Stop in /usr/ports/graphics/ImageMagick/work/ImageMagick-6.4.8-3.
*** Error code 1

Stop in /usr/ports/graphics/ImageMagick/work/ImageMagick-6.4.8-3.
*** Error code 1

Stop in /usr/ports/graphics/ImageMagick/work/ImageMagick-6.4.8-3.
*** Error code 1

Stop in /usr/ports/graphics/ImageMagick.
*** Error code 1

Stop in /usr/ports/multimedia/dvdrip.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?498698F9.1030204>