Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 8 Oct 2012 17:26:50 +0100
From:      Steve O'Hara-Smith <ateve@sohara.org>
To:        Matthias Fechner <idefix@fechner.net>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: ZFS and zpool mistake
Message-ID:  <20121008172650.04011d5a18d710af8d1f23b0@sohara.org>
In-Reply-To: <5072F16A.70505@fechner.net>
References:  <5072F16A.70505@fechner.net>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Mon, 08 Oct 2012 17:29:46 +0200
Matthias Fechner <idefix@fechner.net> wrote:

> Dear list,
> 
> I installed a freebsd with freebsd on a zfs root and only one disk:
>   pool: zroot
>  state: ONLINE
>   scan: none requested
> config:
> 
> 	NAME         STATE     READ WRITE CKSUM
> 	zroot        ONLINE       0     0     0
> 	  ada0p3     ONLINE       0     0     0
> 
> This disk was now insterted into the computer and boots fine.
> The next step I wanted was to setup a mirror with a second disk.
> 
> So I inserted a second disk, configured everything with gpart and added
> the disk to the zroot with:
> zpool add zroot gpt/disk1
> (I think I had to execute zpool add zroot mirror gpt/disk1, this is not
> clear from the man page)

	You need add for a stripe and attach for a mirror.

> And now I have a problem, it seems not to be a mirror but a stripe:
> 	NAME         STATE     READ WRITE CKSUM
> 	zroot        ONLINE       0     0     0
> 	  ada0p3     ONLINE       0     0     0
> 	  gpt/disk1  ONLINE       0     0     0
> 
> Is there any chance to get it into a mirror?
> 
> I don't think there was anything written to the second disk but I cannot
> remove it anymore.

	Yep once you've added a stripe there's no way to remove it. You'll
have to copy the data off somewhere and then rebuild the pool.

-- 
Steve O'Hara-Smith <ateve@sohara.org>



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20121008172650.04011d5a18d710af8d1f23b0>