Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 18 Jan 2010 16:07:00 +0000
From:      Paul B Mahol <onemda@gmail.com>
To:        Christoph Kukulies <kuku@kukulies.org>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: rum0 acting as an Access point (belkin router) 8.0 R
Message-ID:  <3a142e751001180807u4164013cuebaf3038775a08f2@mail.gmail.com>
In-Reply-To: <4B547396.7070902@kukulies.org>
References:  <4B507B9A.3050803@kukulies.org> <3a142e751001150817x7b4da53fs16cebd2e097890b4@mail.gmail.com> <4B547396.7070902@kukulies.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 1/18/10, Christoph Kukulies <kuku@kukulies.org> wrote:
> Paul B Mahol schrieb:
>> On 1/15/10, Christoph Kukulies <kuku@kukulies.org> wrote:
>>
>>> I'm not sure wether syntax has changed but I wanted to cretae an wlan
>>> acess point
>>> and tried various things. Under 7.0 I got it working with the following
>>> command
>>>
>>> ifconfig rum0 inet 10.0.0.1/24 mediaopt hostap ssid CITYOFFICE  wepmode
>>> on wepkey 0xf00baf00ba weptxkey 1 channel 1
>>>
>>>
>>> I tried this but got a socket error "Invalid argument".
>>>
>>> Then I tried (from an example in the rum (4) manpage):ifconfig wlan
>>> create wlandev rum0 10.0.0.1/24 mediaopt hostap CITYOFFICE wepmode on
>>> wepkey 0xf00baaf00baa  weptxkey 1 channel 1
>>>
>>>
>>
>> Perhaps you want this one:
>>
>> ifconfig wlan create wlandev rum0 10.0.0.1/24 wlanmode hostap ssid
>> CITYOFFICE wepmode on wepkey 0xf00baaf00baa  weptxkey 1 channel 1
>>
>>
>
> I tried this in rc.conf:
>
> ifconfig_rum0="wlan create wlandev rum0 10.0.0.1/24 wlanmode hostap ssid
> CITYOFFICE  wepmode on wepkey 0xf00baaf00baa weptxkey 1 channel 1"
>
> I got this:
>
> rum0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
>         ether 00:11:50:cb:52:10
>         media: IEEE 802.11 Wireless Ethernet autoselect <adhoc>
> (autoselect <adhoc>)
>         status: no carrier
>
>
> Why "no carrier"?

You still did not created wlan0 interface:

Put

wlans_rum0="wlan0"

in rc.conf, and instead of

ifconfig_rum0=".....

use

ifconfig_wlan0=".....


-- 
Paul B Mahol



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?3a142e751001180807u4164013cuebaf3038775a08f2>