Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 24 Jan 2011 00:58:07 +0300
From:      Peter Vereshagin <peter@vereshagin.org>
To:        FreeBSD Questions <freebsd-questions@freebsd.org>
Subject:   Re: missing uwacom.ko
Message-ID:  <20110123215806.GB5172@external.screwed.box>
In-Reply-To: <20110123210747.GA56832@guilt.hydra>
References:  <20110123202350.GA56677@guilt.hydra> <20110123210410.GA5172@external.screwed.box> <20110123210747.GA56832@guilt.hydra>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Como esta, FreeBSD?
2011/01/23 14:07:47 -0700 Chad Perrin <perrin@apotheon.com> => To FreeBSD Questions :
CP> > read-only mounted volume.
CP> The /boot directory is on the / partition, with 755 permissions at

It can have any mode and at the same time the volume can be mounted read-only.

CP> > 1. Broken port. Is there any explanation why it's broken? anyway, there should
CP> > be the way to override this although this may may not be a solution depending
CP> > on the reason for port to be broken.
CP> I haven't looked into this in too much depth yet.  The error message just
CP> says it's marked as broken, though.

I forgot it's a freebsd-8.x at yours, I tried and  could not have a wacom deteced on a 8.x ...
The author promises to take a driver upstream in the bas esystem, but it seems to be a long way.
At the moment it seems that only Intuos/Graphire series are supported.

CP> > 2. No uwacom.ko. Are you sure that it doesn't exist in your input-wacom/work
CP> > directory when you successfully built the port?
CP> I didn't build the port.  It got installed as part of the OS install
CP> process, which surprised the heck out of me.  I wonder if I accidentally
CP> selected something I did not intend to install when I was selecting what
CP> sources to include.

But somehow you get an error message. And this message is the one word: "Broken".
Look, it is explicitly noted in the x11-drivers/inpuit-wacom port option:
no uwacom.ko for 8.x.

CP> > 3. You may note that ums(4) compiled into GENERIC statically, should not be
CP> > present in your kernel before you try to kldload uwacom
CP> > http://lists.freebsd.org/pipermail/freebsd-questions/2009-January/189857.html
CP> I'm not sure this makes any difference when there's no wacom kernel
CP> module at all.

There should be a uhid.ko on a 8.x?


73! Peter pgp: A0E26627 (4A42 6841 2871 5EA7 52AB  12F8 0CE1 4AAC A0E2 6627)
--
http://vereshagin.org



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20110123215806.GB5172>