Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 22 Jul 1999 19:34:00 +0800
From:      "Azman Salleh" <azmansl@orenda.com.my>
To:        <freebsd-stable@freebsd.org>
Subject:   DMA on Ide_pci does not work.
Message-ID:  <000001bed436$1b89f0e0$0601010a@a>

Next in thread | Raw E-Mail | Index | Archive | Help
After compiling todays 3.2-STABLE, my new kernel cannot boot. It
seems that the pci_ide fail on DMA mode. It works after changing
to PIO mode. A quick compare on the source tree shows that a new
ide_pci code was check in and some changes on the DMA part.

The error messages is:
---wd0: DMA failure, DMA status 5<active>----


My Kernel Configuration. I tried both flags on the controller
also flags on the disk and get the same result.
----
##controller     wdc0    at isa? port "IO_WD1" bio irq 14 flags
0xb0ffb0ff
controller      wdc0    at isa? port "IO_WD1" bio irq 14
disk            wd0     at wdc0 drive 0 flags 0xb0ff


---Shortened DMESG---------
FreeBSD 3.2-STABLE #4: Thu Jul 22 17:27:07 MYT 1999
FreeBSD/SMP: Multiprocessor motherboard
Probing for devices on PCI bus 0:
chip0: <Intel 82443GX host to PCI bridge> rev 0x00 on pci0.0.0
chip2: <Intel 82371AB PCI to ISA bridge> rev 0x02 on pci0.18.0
ide_pci0: <Intel PIIX4 Bus-master IDE controller> rev 0x01 on
pci0.18.1
wdc0 at 0x1f0-0x1f7 irq 14 on isa
wdc0: unit 0 (wd0): <ST34310A>, LBA, DMA, 32-bit, multi-block-16
wd0: 4111MB (8420832 sectors), 524 cyls, 255 heads, 63 S/T, 512
B/S
.
.
hanging root device to wd0s1a
wd0: DMA failure, DMA status 5<active>
wd0: DMA failure, DMA status 5<active>



To Unsubscribe: send mail to majordomo@FreeBSD.org
with "unsubscribe freebsd-stable" in the body of the message




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?000001bed436$1b89f0e0$0601010a>