Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 29 Oct 2012 16:44:59 +0100
From:      Big Yuuta <init.py@gmail.com>
To:        Alexander Motin <mav@freebsd.org>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: No sound from speaker, using Realtek ALC269 and snd_hda
Message-ID:  <CAN5iB8ShL+BbSHDXhX65_DwiMjAjUpgO273-=VpUYicD_hDjcA@mail.gmail.com>
In-Reply-To: <508DA4D0.8040604@FreeBSD.org>
References:  <CAN5iB8RJe=JY2zsDG40gtCwcf4uJBt0+txiSSuHqnZ1Ob6=HZg@mail.gmail.com> <508D8755.1080501@FreeBSD.org> <CAN5iB8T9RySw4h5HaM=pCA_G8n4yVa+Awdz4_YO8yr-FFk3iZg@mail.gmail.com> <508D98C9.30603@FreeBSD.org> <CAN5iB8QMm80VWzRFMsD=_vDN0HNLCoU2tb-Bt6n5qjUOcLHDXA@mail.gmail.com> <CAN5iB8R--Jm5o57u3_xKwN_5Cd=3zSXEWj42DdxakXptBiYqKQ@mail.gmail.com> <508DA4D0.8040604@FreeBSD.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hi, Alexander

On Sun, Oct 28, 2012 at 10:34 PM, Alexander Motin <mav@freebsd.org> wrote:
> Also check that pin sensing is working. Try to plug in/out headphones. With
> verbose messages enabled, you should see messages about that on console and
> in logs.

Pin sensing works fine. I tested it and whenever I plug the headphone in,
I can hear the sound from the headphone, and I have this output
on the console:

hdaa0: Pin sense: nid=26 sence=0x80000000 (connected)
pcm0: Redirect output to: headphones
hdaa0: Pin sense: nid=26 sence=0x00000000 (disconnected)
pcm0: Redirect output to: main

I think the redirection works, but nid20 is not well set? Is "main" here
the 1st nid of the association? i.e. nid20 which has seq=0?

I hope I'm not bothering you with my questions, and again thanks
a lot for all your work, patience, and help!



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CAN5iB8ShL+BbSHDXhX65_DwiMjAjUpgO273-=VpUYicD_hDjcA>