Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 10 Oct 2013 14:06:00 +0200
From:      =?utf-8?Q?=C5=81ukasz_P?= <admin@3dr.org>
To:        "'Yamagi Burmeister'" <lists@yamagi.org>, <feld@FreeBSD.org>
Cc:        freebsd-hackers@freebsd.org
Subject:   RE: Fuse on FreeBSD 9.2
Message-ID:  <!&!AAAAAAAAAAAYAAAAAAAAAGBeVrDJdalIt05g1povNbHCgAAAEAAAAE1rPIHJR85BhR/U1rBtgJUBAAAAAA==@3dr.org>
In-Reply-To: <20131008140251.3ed4cf7e4af3415c3cde1aa9@yamagi.org>
References:  <!&!AAAAAAAAAAAYAAAAAAAAAGBeVrDJdalIt05g1povNbHCgAAAEAAAADlTn3fThBRHunGcL2yEju0BAAAAAA==@3dr.org>	<1381232043.4996.31392865.263615DD@webmail.messagingengine.com> <20131008140251.3ed4cf7e4af3415c3cde1aa9@yamagi.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hello,
I've tried http://people.freebsd.org/~flo/fusefs-kmod.tar.bz2 on 9.2 - =
unfortunatelly - there's the same problem as with fuse from 10. While =
using MooseFS filesystem changes made on one client node are not visible =
to other clients.
It's like the file content is not being refreshed. There is no such =
problem on 7.4 or 8.4 using regular fusefs-kmod from ports.



Luke

> -----Original Message-----
> From: Yamagi Burmeister [mailto:lists@yamagi.org]
> Sent: Tuesday, October 08, 2013 2:03 PM
> To: feld@FreeBSD.org
> Cc: freebsd-hackers@freebsd.org; admin@3dr.org
> Subject: Re: Fuse on FreeBSD 9.2
>=20
> There's already a backport which can be found here:
> http://people.freebsd.org/~flo/fusefs-kmod.tar.bz2
>=20
> 1. Download, untar and replace your existing sysutils/fusefs-kmod
>    port with it. Open the Makefile and add "NO_STAGE=3D yes" to it.
> 2. cd sysutils/fusefs-kmod ; make makesum ; make deinstall reinstall
>    clean
> 4. Rebuild sysutils/fusefs-libs and all fuse filesystems (don't
>    know if that's necessary but it doesn't hurt either).
>=20
> I've been running with this kernel module on FreeBSD 9-STABLE,
> 9.1 and 9.2 four about one year without any problem. I don't know why =
flo@
> never committed his work.
>=20
> On Tue, 08 Oct 2013 06:34:03 -0500
> Mark Felder <feld@FreeBSD.org> wrote:
>=20
> > On Tue, Oct 8, 2013, at 5:21, =C5=81ukasz P wrote:
> > > Hello,
> > >
> > > Please let me know if anyone is up to fix fuse on FreeBSD 9.x ?
> > >
> > > Particularly this bug:
> > > <http://www.freebsd.org/cgi/query-pr.cgi?pr=3D182739>;
> > > http://www.freebsd.org/cgi/query-pr.cgi?pr=3D182739
> > >
> > >
> > >
> > > I'm willing to pay for the fix.
> > >
> > >
> >
> > I think the "fix" is the new from-scratch fuse module in FreeBSD 10,
> > which in my experience works flawlessly. Perhaps you should instead
> > see if someone is willing to backport that fuse module to 9.x?
> > _______________________________________________
> > freebsd-hackers@freebsd.org mailing list
> > http://lists.freebsd.org/mailman/listinfo/freebsd-hackers
> > To unsubscribe, send any mail to =
"freebsd-hackers-unsubscribe@freebsd.org"
>=20
> --
> Homepage:  www.yamagi.org
> XMPP:      yamagi@yamagi.org
> GnuPG/GPG: 0xEFBCCBCB




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?!&!AAAAAAAAAAAYAAAAAAAAAGBeVrDJdalIt05g1povNbHCgAAAEAAAAE1rPIHJR85BhR/U1rBtgJUBAAAAAA==>