Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 5 Jan 2001 15:44:44 -0500
From:      David Banning <david@www3.pacific-pages.com>
To:        Robert Myers <ccrider@whiterose.net>
Cc:        questions@freebsd.org
Subject:   Re: no samba with inetd start
Message-ID:  <20010105154444.A56360@www3.pacific-pages.com>
In-Reply-To: <000001c075e1$975a68f0$0201a8c0@ccrider2k>; from ccrider@whiterose.net on Wed, Jan 03, 2001 at 10:00:56AM -0500
References:  <20010103013318.A7718@www3.pacific-pages.com> <000001c075e1$975a68f0$0201a8c0@ccrider2k>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help

On Wed, Jan 03, 2001 at 10:00:56AM -0500, Robert Myers wrote:
> You are not looking for it to run all of the time are you?
I don't know.  I just want windows95 to print on my unix box.
When I run 
$ smbd -D
$ nmbd -D

it seems to stay running, and it prints.
When I activate the entries (netbios...) in inetd.conf
there is nothing running, AND it does not print.

I just assumed that it would run so that I could see it with "ps -ax"
While printing does not work in this mode,
it seems to have some effect, as 
$ smbd -D
$ nmbd -D
will not load and run if I boot with the inetd.conf entries present.

> 
> Inetd will only run nmbd and smbd when requests come into the system on that
> port.
> 
> Robert Myers
> Systems Administrator
> http://whiterose.net
> (717)439-1478
> 
> 
> -----Original Message-----
> From: owner-freebsd-questions@FreeBSD.ORG
> [mailto:owner-freebsd-questions@FreeBSD.ORG]On Behalf Of David Banning
> Sent: Wednesday, January 03, 2001 1:33 AM
> To: David
> Cc: David Banning; questions@FreeBSD.ORG
> Subject: Re: no samba with inetd start
> 
> 
> On Tue, Jan 02, 2001 at 05:06:57PM -0800, David wrote:
> > On Tue, Jan 02, 2001 at 07:59:58PM -0500, David Banning wrote:
> > > I have recently installed samba. I seems to run fine
> > > when I run from the shell;
> > >
> > > $ smbd -D
> > > $ nmbd -D
> > >
> > > but when I run it by commenting out the entries in inetd.conf;
> > >
> > > netbios-ssn stream tcp nowait root /usr/local/sbin/sbbd smbd
> > > netbios-ns dgram udp wait root /usr/local/sbin/nmbd nmbd
> > >
> > > it won't run;
> > >
> > > any idea why?
> >
> > I can't give you a reason why other then say "it won't work that way?"
> 
> The only reason I had the belief that it would work that way was this
> tutorial,
> which, other than this problem I brought forward, seemed to work great for
> me.
> The tutorial shows both ways of running samba, but kind of suggests
> that the *right* way is through inetd.
> 
> http://www.freebsddiary.org/samba.html
> 
> Anyway I will run it from rc.d as you suggest. Thanks.
> 
> 
> To Unsubscribe: send mail to majordomo@FreeBSD.org
> with "unsubscribe freebsd-questions" in the body of the message
> 
> 

-- 
Never be led astray onto the path of virtue.


To Unsubscribe: send mail to majordomo@FreeBSD.org
with "unsubscribe freebsd-questions" in the body of the message




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20010105154444.A56360>