Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 30 Jan 2009 15:46:14 +0100
From:      Ewald Jenisch <a@jenisch.at>
To:        freebsd-questions@freebsd.org
Subject:   X.org-update -> screen garbled / settings for xorg.conf?
Message-ID:  <20090130144614.GA4897@aurora.oekb.co.at>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi,

Today I upgraded my system (ports) so I got x.org 7.4 installed.

Given the various entries in /usr/ports/UPDATING about the recent
updates for xorg I wonder what the correct settings/combinations are
for my installation:

I've got hald running as per /etc/rc.conf with hald_enable="YES" as
well as moused (moused_enable=YES in rc.conf).

My login is via console from where I manually start X11 (gnome) via
"startx".

Here's what I've got in my xorg.conf:

# Added after upgrade of X11
Section "ServerFlags"
    Option "AllowEmptyInput" "false"
EndSection

the following entries where there even before the upgrade:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option  "Corekeyboard"
        Option "XkbModel" "pc105"
        Option "XkbRules" "xorg"
        Option "XkbLayout" "de"
        Option "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/sysmouse"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection



Here are my questions:

o) When I start X it basically works, but then I get out of gnome,
ending up at the commandline and start X11 again ("startx"), the
screen becomes garbled and everything freezes completely. Not only is
any input via the console disabled but also no reaction on already
established ssh-sessions - complete lockup.

I'm using the "radeonhd" driver for my graphics card is a ATI Radeon
HD 2400 XT (RV610 chipset).



o) Are the above settings (i.e. AllowEmptyInput and the sections for
keyboard/mouse) correct for my combination of hald and moused running?

Thanks much in advance for your help,
-ewald




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20090130144614.GA4897>