Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 2 May 2005 19:53:08 -0700
From:      "Darren Pilgrim" <dmp@bitfreak.org>
To:        "'Darren Pilgrim'" <dmp@bitfreak.org>, "'Carl Gustavsson'" <carl@thegoodone.mine.nu>
Cc:        freebsd-stable@freebsd.org
Subject:   RE: ndis with Intel 2915 wireless, getting "NDIS ERROR" messagesand deattach on boot
Message-ID:  <000001c54f8b$40b43ed0$9afb40d8@Sonomago>
In-Reply-To: <000d01c54f70$73c0bdf0$9f3598d1@Sonomago>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
> From: Darren Pilgrim
> From: Carl Gustavsson <carl@thegoodone.mine.nu>=20
> >=20
> > Have you tested the iwi-driver?
> > See: http://damien.bergamini.free.fr/ipw/iwi-freebsd.html
>=20
> I haven't yet.  Reading that page has brought up another questions.  =
On
the
> page it says 5-STABLE doesn't support WPA.  My wireless network uses =
WPA.
> Is this still the case?  I know -stable is -stable, but WPA something =
of a
> show-stopper, if you ask me.
>=20
> Fortunately, my neighborhood is a well-covered sea of open "linksys" =
and
> "NETGEAR" APs in default configuration with to test the driver.

I'm using driver version 1.3.4 and firmware version 2.2.  The driver =
appears
to attach just fine:=20

iwi0: <Intel(R) PRO/Wireless 2915ABG MiniPCI> mem 0xdfcfd000-0xdfcfdfff =
irq
5 at device 3.0 on pci3
iwi0: Ethernet address: 00:0e:35:f6:d6:5c
iwi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
iwi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
iwi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps =
24Mbps
36Mbps 48Mbps 54Mbps

However, when I attempt to associate and get an IP address, I get "iwi0:
fatal error" when running dhclient.  Setting debug.iwi=3D10 and
debug.ieee80211=3D10, I get the following debug output when I run the =
firmware
download and dhclient commands:

# iwicontrol iwi0 -d /root/if_iwi/firmware-2.2 -m bss
Firmware cached: boot 6464, ucode 16326, main 166952

# dhclient iwi0
INTR!0x01000000
INTR!0x01000000
Setting MAC address to 00:0e:35:f6:d6:5c
TX!CMD!11!6
INTR!0x00000800
Configuring adapter
TX!CMD!6!20
INTR!0x00000800
Setting power mode to 0
TX!CMD!17!4
INTR!0x00000800
Setting RTS threshold to 2312
TX!CMD!15!4
INTR!0x00000800
Setting .11bg supported rates (12)
TX!CMD!22!16
INTR!0x00000800
Setting .11a supported rates (8)
TX!CMD!22!16
INTR!0x00000800
Setting initialization vector to 693451133
TX!CMD!34!4
INTR!0x00000800
Enabling adapter
TX!CMD!2!0
INTR!0x00000800
ieee80211_next_scan: chan 56->60
Start scanning
TX!CMD!20!60
INTR!0x00000800
INTR!0x00000002
Notification (20)
INTR!0x00000002
Scan channel (36)
INTR!0x00000002
Scan channel (40)
INTR!0x00000002
Scan channel (44)
INTR!0x00000002
Scan channel (48)
INTR!0x00000002
RX!DATA!68!52!58
ieee80211_recv_mgmt: new probe response on chan 52 (bss chan 52) "191" =
from
00:0c:db:81:5e:a8
ieee80211_recv_mgmt: caps 0x401 bintval 100 erp 0x0
ieee80211_recv_mgmt: country info 55 53 20 24 04 11 34 04 17 95 05 1e
INTR!0x00000002
Notification (25)
Scan channel (52)
INTR!0x00000002
RX!DATA!68!56!50
ieee80211_recv_mgmt: new probe response on chan 56 (bss chan 56) "191" =
from
00:0c:db:81:5e:4a
ieee80211_recv_mgmt: caps 0x401 bintval 100 erp 0x0
ieee80211_recv_mgmt: country info 55 53 20 24 04 11 34 04 17 95 05 1e
INTR!0x00000002
Notification (25)
Scan channel (56)
INTR!0x00000002
Scan channel (60)
INTR!0x00000002
Scan channel (64)
INTR!0x00000002
Scan channel (149)
INTR!0x00000002
Scan channel (153)
INTR!0x00000002
Scan channel (157)
INTR!0x40000000
iwi0: fatal error

At which point dhclient stalls for several seconds before switching to =
its
background mode.  `ifconfig iwi0` then shows "status: no carrier" and no =
IP
address assignment.




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?000001c54f8b$40b43ed0$9afb40d8>