Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 22 Feb 2007 13:23:57 +0100
From:      Karol Kwiatkowski <karol.kwiat@gmail.com>
To:        Zbigniew Szalbot <zbyszek@szalbot.homedns.org>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: php upgrade to 5.2.1 fails because of extensions
Message-ID:  <45DD8B5D.5090008@gmail.com>
In-Reply-To: <1257.192.168.11.11.1172138104.squirrel@lists.lc-words.com>
References:  <1257.192.168.11.11.1172138104.squirrel@lists.lc-words.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enigFC068C9015BF5AEF92FF1AD6
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Zbigniew Szalbot wrote:
> Hello,

Hi,

> I know this is not the php list but looking for your advice. I wanted t=
o
> upgraded php 5.1.6 to 5.2.1 because of vulnarabilities but it failed to=

> install extenstions. There seems to be an error with extenstions in 5.2=
=2E1.

What error, which extension? Seems to work fine here:

$ uname -prs
FreeBSD 6.2-STABLE i386
$ pkg_info -Ix php
php5-5.2.1_2        PHP Scripting Language (Apache Module and CLI)
php5-bz2-5.2.1_2    The bz2 shared extension for php
php5-calendar-5.2.1_2 The calendar shared extension for php
php5-ctype-5.2.1_2  The ctype shared extension for php
php5-dom-5.2.1_2    The dom shared extension for php
php5-extensions-1.1 A "meta-port" to install PHP extensions
php5-gd-5.2.1_2     The gd shared extension for php
php5-iconv-5.2.1_2  The iconv shared extension for php
php5-mcrypt-5.2.1_2 The mcrypt shared extension for php
php5-mhash-5.2.1_2  The mhash shared extension for php
php5-openssl-5.2.1_2 The openssl shared extension for php
php5-pcre-5.2.1_2   The pcre shared extension for php
php5-pdo-5.2.1_2    The pdo shared extension for php
php5-pdo_sqlite-5.2.1_2 The pdo_sqlite shared extension for php
php5-posix-5.2.1_2  The posix shared extension for php
php5-session-5.2.1_2 The session shared extension for php
php5-simplexml-5.2.1_2 The simplexml shared extension for php
php5-spl-5.2.1_2    The spl shared extension for php
php5-sqlite-5.2.1_2 The sqlite shared extension for php
php5-tokenizer-5.2.1_2 The tokenizer shared extension for php
php5-xml-5.2.1_2    The xml shared extension for php
php5-xmlreader-5.2.1_2 The xmlreader shared extension for php
php5-xmlwriter-5.2.1_2 The xmlwriter shared extension for php
php5-zlib-5.2.1_2   The zlib shared extension for php


> I cannot downgrade (I issued  sudo portupgrade -m
> -DDISABLE_VULNERABILITIES -f php5 changing the Makefile and distinfo
> entries to point to 5.1.6 and issuing make makesum and got):

No, no, no, don't do that :) Changing port version is not simply as
that. Many times you'll need patches for a specific version in
ports_name/files directory. That is why your attempt failed.

Btw, if you really want to downgrade have a look at
ports-mgmt/portdowngrade.


> Nor can I upgrade as these php5-extenstions won't install. Could anyone=

> advise what to do?

Update your ports tree to a clean one (without your modifications to php
port). Try again (be sure to upgrade any required dependencies), send
errors if any.

Regards,

Karol

--=20
Karol Kwiatkowski   <karol.kwiat at gmail dot com>
OpenPGP 0x06E09309


--------------enigFC068C9015BF5AEF92FF1AD6
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (FreeBSD)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFF3YtjezeoPAwGIYsRCDyUAJ9KzJvZg61FTC4DgZYyGl8UR/6/XACgjDzj
YyVexNaY3FlRIZaKqh3ptQ8=
=e2Fx
-----END PGP SIGNATURE-----

--------------enigFC068C9015BF5AEF92FF1AD6--



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?45DD8B5D.5090008>