Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 13 Dec 2015 08:23:45 +0100
From:      Polytropon <freebsd@edvax.de>
To:        "William A. Mahaffey III" <wam@hiwaay.net>
Cc:        FreeBSD Questions !!!! <freebsd-questions@freebsd.org>
Subject:   Re: problems running OpenGL code
Message-ID:  <20151213082345.4c588242.freebsd@edvax.de>
In-Reply-To: <566C51CB.8040604@hiwaay.net>
References:  <566C3DAD.8090809@hiwaay.net> <20151212173509.fba928df.freebsd@edvax.de> <566C51CB.8040604@hiwaay.net>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sat, 12 Dec 2015 11:02:13 -0553.75, William A. Mahaffey III wrote:
> On 12/12/15 10:41, Polytropon wrote:
> > On Sat, 12 Dec 2015 09:36:23 -0553.75, William A. Mahaffey III wrote:
> > [...]
> > is being defined. For OpenGL, other things like direct
> > rendering (DRI, DRM) might be needed. You can always
> > check this with tools like glxinfo, xdriinfo, glxgears,
> > or other programs that make use of OpenGL (for example,
> > "xlock -mode fire" or "xlock -mode lament").
> >
> > The top of "glxinfo" output should look like this:
> >
> > 	name of display: :0.0
> > 	display: :0  screen: 0
> > 	direct rendering: Yes
> > 	server glx vendor string: NVIDIA Corporation
> > 	server glx version string: 1.4
> > 	server glx extensions:
> > 	[...]
> > 	client glx vendor string: NVIDIA Corporation
> > 	client glx version string: 1.4
> > 	client glx extensions:
> > 	[...]
> > 	GLX version: 1.4
> 
> Hmmmm:
> 
> [root@kabini1, /etc, 10:56:18am] 767 % glxinfo
> glxinfo: Command not found.

It's additional software, if I remember correctly, found in "mesa-demos".

	% glxinfo

and

	% glxgears

provide some information - or will complain when 3D is not available.

The "graphics reality test" requires "xlock" and "xlockmore", and then:

	% xlock -nolock -mode lament
	% xlock -nolock -mode fire
	% xlock -nolock -mode gears

I usually understand those as an indicator of "3D works". :-)



> > Of course your graphics hardware should be reflected accordingly. :-)
> >
> > For this to work, I had to put
> >
> > 	drm_load="YES"
> > 	nvidia_load="YES"
> 
> Hmmmm .... OK, just did  that. Do have them installed:
> 
> [root@kabini1, /etc, 10:56:29am] 769 % grep -i drm LIST.installed.txt
> drm-kmod-9.280208              FreeBSD 9.3 Kernel DRM driver
> libdrm-2.4.60,1                Userspace interface to kernel Direct 
> Rendering Module services
> [root@kabini1, /etc, 10:57:09am] 770 % grep -i nvidia LIST.installed.txt
> nvidia-driver-340-340.93       NVidia graphics card binary drivers for 
> hardware OpenGL rendering
> [root@kabini1, /etc, 10:57:16am] 771 %
> 
> I just 'kldload'-ed drm & nvidia, I'll try again momentarily ....

And you _do_ have a nVidia chipset? Keep in mind the example
I provided is from my home PC equipped with a "NVIDIA GeForce
7600 GS (G73)" (according to "pciconf -lv"). A different kind
of graphics hardware of course requires a different driver.
And it might be possible you have to force X to use the driver
you want. In my xorg.conf, I have the following relevant section:

	Section "Device"
		Identifier	"Card0"
		Driver		"nvidia"
		VendorName	"nVidia Corporation"
		BoardName	"G73 [GeForce 7600 GS]"
		BusID		"PCI:2:0:0"
		Screen		0
		Option		"NvAGP"			"3"
		Option		"UseEdid"		"FALSE"
		Option		"UseEdidDpi"		"FALSE"
		Option		"DPI"			"96 x 96"
	EndSection

There is other statically hardcoded stuff in my xorg.conf, but
this example should illustrate how a specific driver can be
forced when leaving X's autodetection magic aside. :-)



> >> Am I hosed until 3D OpenGL works for AMD jaguars ? If so, how is
> >> progress on that front ? These are fairly common APUs, widely used in
> >> laptops, some low-end desktops & some tablets, it would be sweet to get
> >> this going :-) ....
> > As far as I know, this special kind of "graphics card" isn't that
> > easy to use. It starts with the proper driver. Which one are you
> > currently using?
> 
> Uuuuuuuuuhhhh .... Not sure. VESA, I think, how do I check ?

Check "pciconf -lv" to see what you _really_ have, then /var/log/Xorg.0.log
to find out what X _thinks_ you have. In my case, the relevant lines
look like this:

	(II) LoadModule: "nvidia"
	(II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
	(II) Module nvidia: vendor="NVIDIA Corporation"
	        compiled for 4.0.2, module version = 1.0.0
	        Module class: X.Org Video Driver

Also make sure you have entries like 

	(II) LoadModule: "glx"
	(II) LoadModule: "dri"
	(II) LoadModule: "dri2"

in that log file.


-- 
Polytropon
Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20151213082345.4c588242.freebsd>