Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 29 Apr 2020 17:18:07 -0400
From:      ajtiM <starikarp@dismail.de>
To:        Robert Huff <roberthuff@rcn.com>
Cc:        FreeBSD Questions <freebsd-questions@freebsd.org>
Subject:   Re: Firefox 76.0,1
Message-ID:  <20200429171807.294a1fac@dismail.de>
In-Reply-To: <24232.59798.585406.321666@jerusalem.litteratus.org>
References:  <20200428191142.5cf10bbc@dismail.de> <24232.59798.585406.321666@jerusalem.litteratus.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Tue, 28 Apr 2020 22:42:30 -0400
Robert Huff <roberthuff@rcn.com> wrote:

>=20
> ajtiM via freebsd-questions writes:
>=20
> >  I do not have installed Python 2.7 but today I want to update
> > Firefox to version 76.0,1 and it pull me Python 2.7.
> >  I have checkmarks on DBUS, FFMPEG, GCONF, OPTIMAZED_CFLAGS,
> > PROFILE and SNDIO.
> >   make
> >  =3D=3D=3D>   firefox-76.0,1 depends on package: nspr>=3D4.25 - found
> >  =3D=3D=3D>   firefox-76.0,1 depends on package: nss>=3D3.51.1 - found
> >  =3D=3D=3D>   firefox-76.0,1 depends on package: icu>=3D64.1,1 - found
> >  =3D=3D=3D>   firefox-76.0,1 depends on package: libevent>=3D2.1.8 - fo=
und
> >  =3D=3D=3D>   firefox-76.0,1 depends on package: harfbuzz>=3D2.6.4 - fo=
und
> >  =3D=3D=3D>   firefox-76.0,1 depends on package: graphite2>=3D1.3.14 - =
found
> >  =3D=3D=3D>   firefox-76.0,1 depends on package: png>=3D1.6.35 - found
> >  =3D=3D=3D>   firefox-76.0,1 depends on package: libvpx>=3D1.8.2 - found
> >  =3D=3D=3D>   firefox-76.0,1 depends on package: py37-sqlite3>0 - found
> >  =3D=3D=3D>   firefox-76.0,1 depends on package: v4l_compat>0 - found
> >  =3D=3D=3D>   firefox-76.0,1 depends on executable: autoconf-2.13 - fou=
nd
> >  =3D=3D=3D>   firefox-76.0,1 depends on executable: nasm - found
> >  =3D=3D=3D>   firefox-76.0,1 depends on executable: yasm - found
> >  =3D=3D=3D>   firefox-76.0,1 depends on executable: zip - found
> >  =3D=3D=3D>   firefox-76.0,1 depends on package: llvm90>0 - found
> >  =3D=3D=3D>   firefox-76.0,1 depends on package: rust-cbindgen>=3D0.13.=
1 -
> > found =3D=3D=3D>   firefox-76.0,1 depends on package: rust>=3D1.41 - fo=
und
> >  =3D=3D=3D>   firefox-76.0,1 depends on file: /usr/local/bin/python3.7 -
> > found =3D=3D=3D>   firefox-76.0,1 depends on executable: node - found
> >  =3D=3D=3D>   firefox-76.0,1 depends on file: /usr/local/bin/clang90 -
> > found =3D=3D=3D>   firefox-76.0,1 depends on package: libnotify>0 - fou=
nd
> >  =3D=3D=3D>   firefox-76.0,1 depends on file: /usr/local/include/sndio.=
h -
> >  found =3D=3D=3D>   firefox-76.0,1 depends on executable: gmake - found
> >  =3D=3D=3D>   firefox-76.0,1 depends on package: libiconv>=3D1.14_11 - =
found
> >  =3D=3D=3D>   firefox-76.0,1 depends on package: pkgconf>=3D1.3.0_1 - f=
ound
> >  =3D=3D=3D>   firefox-76.0,1 depends on file: /usr/local/bin/python2.7 -
> > not
>=20
> 	_If_ I have this right:
> 	Firefox requires pkgconf ... which - if DOCS=3Dyes - requires
> ImageMagic ... which requires (in your case) python 2.7.
> 	See if you can rebuild your versiou of ImageMagic against
> python 3.7, and this should go away.
>=20
>=20
>=20
> 			Respectfully,
>=20
>=20
> 				Robert Huff
>=20
>=20
>=20

Thank you but I do not have ImageMagick. I did build Inkscape 0.92.5
which use GraphicsMagick.
And

  portmaster --check-depends
Checking all packages: 100%



--=20
Ernst Lubitsch=E2=80=99s Ninotchka:=20

=E2=80=9C=E2=80=98Waiter! A cup of coffee without cream, please!=E2=80=99 =
=E2=80=98I=E2=80=99m sorry, sir, we
have no cream, only milk, so can it be a coffee without milk?=E2=80=99=E2=
=80=9D=20



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20200429171807.294a1fac>