Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 09 Oct 2012 13:52:00 +0200
From:      Bernt Hansson <bah@bananmonarki.se>
To:        "Ronald F. Guilmette" <rfg@tristatelogic.com>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: Audio out via HDMI... how?
Message-ID:  <50740FE0.5000508@bananmonarki.se>
In-Reply-To: <28733.1349783186@tristatelogic.com>
References:  <28733.1349783186@tristatelogic.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help


2012-10-09 13:46, Ronald F. Guilmette skrev:
>
>
> I have a laptop which has an HDMI output port.
>
> I can get video out of that (with xbmc) just fine.  Audio, not so much.
> Like not at all, as far as I can tell.
>
> So anyway, here is what I get when I do "cat /dev/sndstat":
>
> pcm0: <HDA Realtek ALC888 PCM #0 Analog> (play/rec) default
> pcm1: <HDA Realtek ALC888 PCM #1 Analog> (rec)
> pcm2: <HDA Intel Cantiga HDMI PCM #0 HDMI> (play)

As root sysctl hw.snd.default_unit=2

> I have the HDMI output wired into my everything-capable Sony 5.1 channel
> receiver, which then in turn is wired into my 4 (count 'em four) speakers.
>
> OK, so now, could somebody please just tell me how I can do a test
> that will determine why I ain't gettin' no audio?
>
> The receiver is capable of decoding 5.1 DTS-HD, Dolby TrueHD, and eveything
> else too.  It is working just fine.. not a thing wrong with it.  It works
> great with my Blu-Ray player and does the digital->analog decoding for
> anything and everything I throw at it.
>
> Again, I just want to know how to _test_ doing some output to that from
> my laptop, via HDMI.  I tried these things, but not a sound was heard:
>
>     cat /dev/random > /dev/dsp
>
>     cat /dev/random > /dev/dsp2
>
> The FreeBSD handbook page that deal with setiing up audio cards doesn't
> provide a whole lot of guidance for how to test and/or fix digital audio
> output, whether it is coming out via HDMI (as in my case) or via any other
> kind of physical transport (e.g. coax or S/PDIF).
>
> Somwebody please pass me a clue.  I'd really like to get this working.
> Thanks.
>
> P.S.  If I have to downmix to 2ch in xbmc before the audio even hits the
> HDMI cable, I could even live with that.  Bu right now, as far as I can
> tell, I can't get _any_ audio flowing down that cable, period.
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe@freebsd.org"
>
>



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?50740FE0.5000508>