Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 14 Sep 2017 11:23:59 -0400
From:      "James B. Byrne" <byrnejb@harte-lyne.ca>
To:        freebsd-questions@freebsd.org
Subject:   Perl5.24.2?
Message-ID:  <9172c06a79667cf19cb8df58baafb2f3.squirrel@webmail.harte-lyne.ca>

Next in thread | Raw E-Mail | Index | Archive | Help
I am trying to build a perl module (p5-DBD-Pg) which has the following
setting in its Makefile:

USE_PERL5=configure

However, this gives the error that perl5.24.2 cannot be found. 
Perl5.24.1 is the version available through the package manager.  I am
not comfortable with replacing the current version of Perl system-wide
so I would like to simply have the module build with installed
version.

If I set USE_PERL5=5.24+ then the make file fails.  If I set
USE_PERL5=5.24+ configure then it goes back to asking for and failing
to find perl5.24.2.  How do I tell the module to use perl5.24.1 AND
get it to configure?


-- 
***          e-Mail is NOT a SECURE channel          ***
        Do NOT transmit sensitive data via e-Mail
 Do NOT open attachments nor follow links sent by e-Mail

James B. Byrne                mailto:ByrneJB@Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?9172c06a79667cf19cb8df58baafb2f3.squirrel>