Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 11 Jun 2013 08:15:55 +0800
From:      Martin Wilke <miwi@freebsd.org>
To:        "mono@freebsd.org" <mono@FreeBSD.org>
Subject:   Fwd: fsharp-3.0.25_1 failed on amd64 10-exp
Message-ID:  <49F50A45-408E-412A-9064-5F9FB3CC234F@freebsd.org>
References:  <201306101012.r5AACauS081345@pointyhat-west.isc.freebsd.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help


Begin forwarded message:

> From: Portbuild user <portbuild@FreeBSD.org>
> Subject: fsharp-3.0.25_1 failed on amd64 10-exp
> Date: June 10, 2013 6:12:36 PM GMT+08:00
> To: miwi@freebsd.org
>=20
> You can also find this build log at
>=20
>  =
http://pointyhat-west.isc.freebsd.org/errorlogs/amd64-errorlogs/a.10-exp.2=
0130608124308.pointyhat-west/fsharp-3.0.25_1.log
>=20
> building fsharp-3.0.25_1 on gohan62.freebsd.org
> in directory =
/a/pkgbuild/10-exp/20130608124308.pointyhat-west/chroot/70863
> building for: 10.0-CURRENT amd64
> maintained by: mono@FreeBSD.org
> port directory: /usr/ports/lang/fsharp
> Makefile ident: $FreeBSD: head/lang/fsharp/Makefile 316355 2013-04-23 =
14:20:25Z bapt $
> build started at Mon Jun 10 10:11:44 UTC 2013
> FETCH_DEPENDS=3D
> PATCH_DEPENDS=3D
> EXTRACT_DEPENDS=3D
> BUILD_DEPENDS=3Dautoconf-2.69.txz autoconf-wrapper-20101119.txz =
gamin-0.1.10_5.txz gettext-0.18.1.1_1.txz gio-fam-backend-2.34.3.txz =
glib-2.34.3.txz gmake-3.82_1.txz libffi-3.0.13.txz libiconv-1.14_1.txz =
m4-1.4.16_1,1.txz mono-3.0.3_2.txz pcre-8.33.txz perl-5.14.2_3.txz =
pkgconf-0.9.2_1.txz python27-2.7.5.txz
> RUN_DEPENDS=3Dgamin-0.1.10_5.txz gettext-0.18.1.1_1.txz =
gio-fam-backend-2.34.3.txz glib-2.34.3.txz libffi-3.0.13.txz =
libiconv-1.14_1.txz mono-3.0.3_2.txz pcre-8.33.txz perl-5.14.2_3.txz =
python27-2.7.5.txz
> PKG_DEPENDS=3Dpkg-1.0.12_1.txz
> prefixes: LOCALBASE=3Dusr/local
> add_pkg pkg-1.0.12_1.txz
> adding dependencies
> adding package pkg-1.0.12_1.txz
> pkg-static: No package(s) matching pkg-1.0.12_1
> Installing pkg-1.0.12_1... done
> If you are upgrading from the old package format, first run:
>=20
>  # pkg2ng
> add_pkg
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D<phase 1: =
make checksum>=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=

> =3D=3D=3D>  License AL2 accepted by the user
> =3D=3D=3D>   fsharp-3.0.25_1 depends on file: /usr/local/sbin/pkg - =
found
> =3D> 3.0.25 doesn't seem to exist in /tmp/distfiles/.
> =3D> Attempting to fetch =
ftp://ftp-master.freebsd.org/pub/FreeBSD/ports/distfiles//3.0.25
> 3.0.25                                                   0  B    0  =
Bps
> =3D=3D=3D> Fetching all distfiles required by fsharp-3.0.25_1 for =
building
> =3D> SHA256 Checksum OK for 3.0.25.
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D<phase 2: =
make extract>=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
> add_pkg
> =3D=3D=3D>  License AL2 accepted by the user
> =3D=3D=3D>   fsharp-3.0.25_1 depends on file: /usr/local/sbin/pkg - =
found
> =3D=3D=3D> Fetching all distfiles required by fsharp-3.0.25_1 for =
building
> =3D=3D=3D>  Extracting for fsharp-3.0.25_1
> =3D> SHA256 Checksum OK for 3.0.25.
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D<phase 3: =
make patch>=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
> add_pkg
> =3D=3D=3D>  Patching for fsharp-3.0.25_1
> =3D=3D=3D>  Applying FreeBSD patches for fsharp-3.0.25_1
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D<phase 4: =
make build>=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
> add_pkg autoconf-2.69.txz autoconf-wrapper-20101119.txz =
gamin-0.1.10_5.txz gettext-0.18.1.1_1.txz gio-fam-backend-2.34.3.txz =
glib-2.34.3.txz gmake-3.82_1.txz libffi-3.0.13.txz libiconv-1.14_1.txz =
m4-1.4.16_1,1.txz mono-3.0.3_2.txz pcre-8.33.txz perl-5.14.2_3.txz =
pkgconf-0.9.2_1.txz python27-2.7.5.txz
> adding dependencies
> adding package autoconf-2.69.txz
> Installing autoconf-2.69...Installing autoconf-wrapper-20101119... =
done
> Installing m4-1.4.16_1,1... done
> Installing perl-5.14.2_3...Removing stale symlinks from /usr/bin...
>    Skipping /usr/bin/perl
>    Skipping /usr/bin/perl5
> Done.
> Creating various symlinks in /usr/bin...
>    Symlinking /usr/local/bin/perl5.14.2 to /usr/bin/perl
>    Symlinking /usr/local/bin/perl5.14.2 to /usr/bin/perl5
> Done.
> Cleaning up /etc/make.conf... Done.
> Spamming /etc/make.conf... Done.
> done
> done
> adding package autoconf-wrapper-20101119.txz
> skipping autoconf-wrapper-20101119, already added
> adding package gamin-0.1.10_5.txz
> Installing gamin-0.1.10_5...Installing gettext-0.18.1.1_1...Installing =
libiconv-1.14_1... done
> done
> Installing glib-2.34.3...Installing libffi-3.0.13... done
> Installing pcre-8.33... done
> Installing python27-2.7.5... done
> No schema files found: doing nothing.
> done
> done
> =3D=3D=3D=3D
> Note that some of the standard modules are provided as separate
> ports since they require extra dependencies:
>=20
> bsddb           databases/py-bsddb
> gdbm            databases/py-gdbm
> sqlite3         databases/py-sqlite3
> tkinter         x11-toolkits/py-tkinter
>=20
> Install them as needed.
> =3D=3D=3D=3D
> =
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D
>=20
> Gamin will only provide realtime notification of changes for at most n =
files,
> where n is the minimum value between (kern.maxfiles * 0.7) and
> (kern.maxfilesperproc - 200). Beyond that limit, files will be polled.
>=20
> If you often open several large folders with Nautilus, you might want =
to
> increase the kern.maxfiles tunable (you do not need to set
> kern.maxfilesperproc, since it is computed at boot time from =
kern.maxfiles).
>=20
> For a typical desktop, add the following line to /boot/loader.conf, =
then
> reboot the system:
>=20
>    kern.maxfiles=3D"25000"
>=20
> The behavior of gamin can be controlled via the various gaminrc files.
> See http://www.gnome.org/~veillard/gamin/config.html on how to create
> these files.  In particular, if you find gam_server is taking up too =
much
> CPU time polling for changes, something like the following may help
> in one of the gaminrc files:
>=20
> # reduce polling frequency to once per 10 seconds
> # for UFS file systems in order to lower CPU load
> fsset ufs poll 10
>=20
> =
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D
> adding package gettext-0.18.1.1_1.txz
> skipping gettext-0.18.1.1_1, already added
> adding package gio-fam-backend-2.34.3.txz
> Installing gio-fam-backend-2.34.3... done
> adding package glib-2.34.3.txz
> skipping glib-2.34.3, already added
> adding package gmake-3.82_1.txz
> Installing gmake-3.82_1... done
> adding package libffi-3.0.13.txz
> skipping libffi-3.0.13, already added
> adding package libiconv-1.14_1.txz
> skipping libiconv-1.14_1, already added
> adding package m4-1.4.16_1,1.txz
> skipping m4-1.4.16_1,1, already added
> adding package mono-3.0.3_2.txz
> Installing mono-3.0.3_2... done
> =
************************************************************************
> If you have build/runtime errors with Mono and Gtk# apps please try =
the
> following first:
>=20
> * Build Mono and gtk+ (x11-toolkits/gtk20) without CPUTYPE and with =
the
>  default FreeBSD CFLAGS ('-O2 -fno-strict-aliasing -pipe') as Mono has
>  been known to expose compiler bugs.
>=20
> * Try building and running Mono with the GENERIC kernel.
>  - Mono requires SYSVSHM, SYSVMSG, and SYSVSEM which are part of the
>    GENERIC kernel.
>  - Removing kernel options or changing defaults to use experimental
>    options can adversely affect Mono's ability to build and run.
>=20
> * Remove leftover semaphores / increase semaphore limits.
>  - Close apps which use Mono and run `ipcs -sbt`.  Remove the
>    semaphores with MODE "--rw-------" and NSEMS "8" using ipcrm (1)
>  - _OR_ simply reboot which is the safest method.
>  - On multi-user systems the semaphore limits may need to be increased
>    from the defaults. The following should comfortably support 30 =
users.
>=20
>    # echo "kern.ipc.semmni=3D40" >> /boot/loader.conf
>    # echo "kern.ipc.semmns=3D300" >> /boot/loader.conf
>=20
> * If you are in a jailed environment, ensure System V IPC are enabled.
>  You can rely on the security.jail.sysvipc_allowed  sysctl to check
>  this status.  The following enables this feature on the host system:
>    # echo "jail_sysvipc_allow=3D\"YES\"" >> /etc/rc.conf
>=20
> * Some process information are acceded through /proc (e.g. when using
>  NUnit) and procfs(5) has to be mounted for these features to work:
>    # echo "proc            /proc   procfs  rw 0 0" >> /etc/fstab
> =
************************************************************************
> adding package pcre-8.33.txz
> skipping pcre-8.33, already added
> adding package perl-5.14.2_3.txz
> skipping perl-5.14.2_3, already added
> adding package pkgconf-0.9.2_1.txz
> Installing pkgconf-0.9.2_1... done
> adding package python27-2.7.5.txz
> skipping python27-2.7.5, already added
> =3D=3D=3D>   fsharp-3.0.25_1 depends on package: mono>=3D3.0 - found
> =3D=3D=3D>   fsharp-3.0.25_1 depends on executable: pkgconf - found
> =3D=3D=3D>   fsharp-3.0.25_1 depends on executable: gmake - found
> =3D=3D=3D>   fsharp-3.0.25_1 depends on file: =
/usr/local/bin/autoconf-2.69 - found
> =3D=3D=3D>  Configuring for fsharp-3.0.25_1
> configure: loading site script /usr/ports/Templates/config.site
> checking whether gmake sets $(MAKE)... yes
> checking for pkg-config... /usr/local/bin/pkg-config
> checking for mono-sgen... /usr/local/bin/mono-sgen
> configure: creating ./config.status
> config.status: creating launcher
> config.status: creating Makefile
> config.status: creating config.make
> config.status: creating src/fsharp/Makefile
> config.status: creating src/fsharp/FSharp.Build-proto/Makefile
> config.status: creating src/fsharp/FSharp.Compiler-proto/Makefile
> config.status: creating src/fsharp/Fsc-proto/Makefile
> config.status: creating src/fsharp/FSharp.Core/Makefile
> config.status: creating src/fsharp/FSharp.Build/Makefile
> config.status: creating src/fsharp/FSharp.Compiler/Makefile
> config.status: creating src/fsharp/Fsc/Makefile
> config.status: creating =
src/fsharp/FSharp.Compiler.Interactive.Settings/Makefile
> config.status: creating =
src/fsharp/FSharp.Compiler.Server.Shared/Makefile
> config.status: creating src/fsharp/fsi/Makefile
> config.status: creating src/fsharp/fsiAnyCpu/Makefile
> config.status: creating src/fsharp/policy.2.0.FSharp.Core/Makefile
> config.status: creating src/fsharp/policy.4.0.FSharp.Core/Makefile
> config.status: creating src/fsharp/policy.2.3.FSharp.Core/Makefile
> config.status: creating src/fsharp/policy.4.3.FSharp.Core/Makefile
> =3D=3D=3D>  Building for fsharp-3.0.25_1
> gmake -C src/fsharp all
> gmake[1]: Entering directory =
`/work/a/ports/lang/fsharp/work/fsharp-3.0.25/src/fsharp'
> gmake do-proto
> gmake[2]: Entering directory =
`/work/a/ports/lang/fsharp/work/fsharp-3.0.25/src/fsharp'
> gmake -C FSharp.Build-proto do-proto
> gmake[3]: Entering directory =
`/work/a/ports/lang/fsharp/work/fsharp-3.0.25/src/fsharp/FSharp.Build-prot=
o'
> mkdir -p .libs//
> mkdir -p .libs//2.0
> mkdir -p .libs//4.0
> mono --gc=3Dsgen =
/work/a/ports/lang/fsharp/work/fsharp-3.0.25/lib/bootstrap/4.0/../2.0/fssr=
gen.exe ../FSharp.Build/FSBuild.txt .libs/FSBuild.fs .libs/FSBuild.resx
> sgen is not supported when using --with-tls=3Dpthread.
>=20
> Stacktrace:
>=20
> gmake[3]: *** [.libs/FSBuild.resources] Abort trap (core dumped)
> gmake[3]: Leaving directory =
`/work/a/ports/lang/fsharp/work/fsharp-3.0.25/src/fsharp/FSharp.Build-prot=
o'
> gmake[2]: *** [do-proto] Error 2
> gmake[2]: Leaving directory =
`/work/a/ports/lang/fsharp/work/fsharp-3.0.25/src/fsharp'
> gmake[1]: *** [all] Error 2
> gmake[1]: Leaving directory =
`/work/a/ports/lang/fsharp/work/fsharp-3.0.25/src/fsharp'
> gmake: *** [all] Error 2
> *** Error code 1
>=20
> Stop.
> make: stopped in /a/ports/lang/fsharp
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
> build of /usr/ports/lang/fsharp ended at Mon Jun 10 10:12:34 UTC 2013
>=20

+-----------------oOO--(_)--OOo-------------------------+
With best Regards,
       Martin Wilke (miwi_(at)_FreeBSD.org)

Mess with the Best, Die like the Rest




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?49F50A45-408E-412A-9064-5F9FB3CC234F>