Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 15 Nov 2020 14:03:37 +0300
From:      "N.J.Terry" <newton.ja.terry@gmail.com>
To:        freebsd-questions@freebsd.org
Subject:   Re: middleman
Message-ID:  <33b45304-30de-6f20-c0a0-3575154fab98@gmail.com>
In-Reply-To: <5ee5097d-2fce-51ad-2700-5efd0f9c6508@dreamchaser.org>
References:  <5ee5097d-2fce-51ad-2700-5efd0f9c6508@dreamchaser.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 15.11.20 08:32, Gary Aitken wrote:
> I'm trying to get up to speed on a project that was started using 
> middleman.
> I'm a naive ruby user and mostly clueless about middleman, so any help and
> pointers would be much appreciated.
> 
> I installed the package, which left a binary named "mman" but no middleman:
> 
> $pkg info -l middleman
> middleman-1.9.1_2:
>          /usr/local/bin/mman
>          /usr/local/etc/mman.xml.sample
>          /usr/local/etc/rc.d/mman.sh.sample
>          /usr/local/man/man8/mman.8.gz
>          /usr/local/share/doc/middleman/README.html
>          /usr/local/share/doc/middleman/filter.pl
> 
> However, substituting "mman" for "middleman" in the examples on the 
> middleman
> site
>    https://middlemanapp.com/
> lead to other anomalies:
> 
> $ mman init test_proj
> config file option missing


The www/middleman package you have installed is a filtering proxy server 
( http://middle-man.sourceforge.net ), not the Middleman static site 
generator framework ( https://middlemanapp.com ).

The latter isn't available as port/package.


> 
> I then tried
> #gem install middleman
> 
> which did install a bunch of gems, but then I get different errors:
> $   middleman init test_proj
> Traceback (most recent call last):
>          16: from /usr/local/bin/middleman:23:in `<main>'
>          15: from /usr/local/bin/middleman:23:in `load'
>          14: from 
> /usr/local/lib/ruby/gems/2.6/gems/middleman-cli-4.3.11/bin/middleman:49:in 
> `<top (required)>'
> ...
> /usr/local/lib/ruby/gems/2.6/gems/execjs-2.7.0/lib/execjs/runtimes.rb:58:in 
> `autodetect': Could not find a JavaScript runtime. See 
> https://github.com/rails/execjs for a list of available runtimes. 
> (ExecJS::RuntimeUnavailable)


Have you looked at the site https://github.com/rails/execjs for a list 
of available runtimes?


> 
> Shouldn't the gems and runtimes have been installed with the pkg?
> 
> Can anyone explain to me what's going on?








Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?33b45304-30de-6f20-c0a0-3575154fab98>