Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 18 May 2020 23:25:58 +0000
From:      greg@unrelenting.technology
To:        "Dan Kotowski" <dan.kotowski@a9development.com>
Cc:        "John-Mark Gurney" <jmg@funkthat.com>, freebsd-arm@freebsd.org
Subject:   Re: FreeBSD on Layerscape/QorIQ LX2160X
Message-ID:  <947c2f9bfaad823a2b104b8741502b40@unrelenting.technology>
In-Reply-To: <-993X5kyX6HEebSKMfqeSWmICCLli6PEFDf82ulKUdk49KTg9sf2u6V_4a8wWQGyFpwtgdXwqvk2kIjFm5u_ZWw6t2qGw5nSV7f-O_96U_g=@a9development.com>
References:  <-993X5kyX6HEebSKMfqeSWmICCLli6PEFDf82ulKUdk49KTg9sf2u6V_4a8wWQGyFpwtgdXwqvk2kIjFm5u_ZWw6t2qGw5nSV7f-O_96U_g=@a9development.com> <eG5oKZGzo-y7vxv1fxUTT4fqnlao8e3KpGlswwhQtC6u1zPFDbHJ04Xdl6V1_bkqNNUgrAi3Yy8GJErFDyIZ9HB4p0q0lLED-bj_YZCdSVY=@a9development.com> <7AFDA7E0-82EC-4CD2-BB03-B7E33D019EDA@unrelenting.technology> <_lvahpuNQE69s4KpHud6ANL6yzL3RCVI-MTyB0_J_ULyW-3UWsqAXnm5gfoFcOyvfRQRabZk4Z4bQgyp15a001kA-WcvsvnWcjqgMBkgGTY=@a9development.com> <BB317821-62C7-416E-83E6-69101A64E9A3@unrelenting.technology> <cjE8j_Tehwtmk7Aw0hzP-EZxwfAQC4ywIrgcqrarkCiRI_X5kacVsJHpaX_SMO9QHVCqfEdJH45eC4AE2cwzfx9nmHzWbhE7M-h09hDe8MA=@a9development.com> <7F9D7164-2C04-4E27-85F9-A495EAC8FC84@unrelenting.technology> <63b4f78ff4ee07359a345bcbc03afeaa@unrelenting.technology> <2053cd2299b81860deecc638ef839d1f@unrelenting.technology> <0012917d629a48e9fcd8589f4f002e1b@unrelenting.technology>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
May 19, 2020 1:29 AM, "Dan Kotowski" <dan.kotowski@a9development.com> wro=
te:=0A=0A>> You still should do kern.cfg.order=3Dacpi, is it on?=0A> =0A>=
 Weirdly when I set that it hangs and drops into the mountroot> shell aga=
in, while leaving it unset=0A> lets me boot into the installer.=0A> =0A> =
https://gist.github.com/agrajag9/171b2665c24baece898ec5ba22439a54=0A=0AOk=
ay, so now you have PCIe but not USB.=0A=0A(You're reading the log, right=
? Not weird to see mountroot if you haven't seen USB in the log.)=0A=0AAc=
tually SATA is supposed to work too, it's odd that you're not seeing AHCI=
.=0A(I was being stupid when I said they have custom SATA, lol)=0AAlso, t=
here's generic PNP0D40 for SDHCI, but we don't recognize that. we should.=
=0A=0AMake sure your firmware is up to date, is your edk2-platforms=0Aexa=
ctly the same as master-lx2160a branch on github currently?=0A=0ASpecific=
ally make sure these changes are in:=0A=0Ahttps://github.com/SolidRun/edk=
2-platforms/commit/97e6b0a36a925f57568d8e411666cfb5034aa38b=0Ahttps://git=
hub.com/SolidRun/edk2-platforms/commit/24698f90b79facfbbfc4067b39a4ddf8c7=
fdfa88=0A=0ATest on that linked build if the log was from your build, and=
 vice versa.=0A=0AHere's a kernel that should also recognize SDHCI (eMMC?=
),=0Awith the amdgpu driver as a bonus :)=0Ahttps://send.firefox.com/down=
load/4dd9b553bfe88cb3/#URS-DESsR8WTsiGutrJlRg



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?947c2f9bfaad823a2b104b8741502b40>