Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 08 Jan 2016 12:00:10 -0500
From:      Andre Goree <andre@drenet.net>
To:        freebsd-questions@freebsd.org
Subject:   Cannot upgrade Perl5
Message-ID:  <6753f041ff5192d0b4bb96bd5bf44ace@drenet.net>

Next in thread | Raw E-Mail | Index | Archive | Help
I read the UPDATING message regarding perl serveral months ago, but 
since I used the default version of perl, I disregarded it -- UPDATING 
mentions only needing to take action if you were NOT using the default 
version.

Here is the issue I'm running into today:

agoree@anet ~ % portupgrade perl5
Password:
[Reading data from pkg(8) ... - 403 packages found - done]
** Port deleted on 2015-12-31: lang/perl5.16
         Has expired: Unsupported, please upgrade to a more recent 
version of Perl
** Listing the failed packages (-:ignored / *:skipped / !:failed)
         - lang/perl5.16 (port deleted)
agoree@anet ~ % pkg info -x perl
...
perl5-5.16.3_24
...


How exactly would I go about upgrading perl5 given the above error?  
Perhaps forcing an uninstall and reinstalling it?  I suppose I'd then 
have to rebuild everything that depends on Perl5?


-- 
Andre Goree
-=-=-=-=-=-
Email     - andre at drenet.net
Website   - http://www.drenet.net
PGP key   - http://www.drenet.net/pubkey.txt
-=-=-=-=-=-



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?6753f041ff5192d0b4bb96bd5bf44ace>