Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 28 Jul 2008 12:28:27 +0200
From:      "Marcel Grandemange" <thavinci@thavinci.za.net>
To:        <questions@freebsd.org>
Cc:        steyn@e-soul.co.za
Subject:   wget vs fetch
Message-ID:  <!&!AAAAAAAAAAAYAAAAAAAAAGJPLKnJoyJDpeEQzt+keprCgAAAEAAAAJuuPBPd+UJFpVZe5G9ZXmsBAAAAAA==@thavinci.za.net>

Next in thread | Raw E-Mail | Index | Archive | Help
I have a problem with a box I upgraded from FreeBSD 6.2 To FreeBSD7

 

It seems the following is happening when I try use portupgrade -a or even
building ports.

ALL transfers that are FTP fail.

 

Now to make this simple, I have following environmental variables set..

 

http_proxy=http://192.168.12.4:3128/

ftp_proxy=http://192.168.12.1:3128/

FTP_PASSIVE_MODE=YES

 

And here is the strange thing..

Fetch fails, but if I use wget there is no problem.

The firewall does allow ftp to go directly aswell, so I have also tried
leaving out any and all proxy settings, this fails aswell. (Except for wget
once again)

 

And here is the crux.

 

I have 5 mahcines on SAME network that has no issues like this, so this
makes me think fetch is broke somehow.

How can I force FreeBSD to use wget instead of fetch to bypass this?

 

 

Ive tried setting env FETCH_CMD=wget but that results in wget failing with
msg:

 

Try `wget --help' for more options.

=> Attempting to fetch from http://mirror.sg.depaul.edu/pub/security/nmap/.

wget: invalid option --

Usage: wget [OPTION]... [URL]...

 

 

 

Thankx ahead!

 




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?!&!AAAAAAAAAAAYAAAAAAAAAGJPLKnJoyJDpeEQzt+keprCgAAAEAAAAJuuPBPd+UJFpVZe5G9ZXmsBAAAAAA==>