Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 6 Feb 2012 15:02:01 -0500
From:      Rick Miller <vmiller@hostileadmin.com>
To:        =?ISO-8859-1?Q?Erik_N=F8rgaard?= <norgaard@locolomo.org>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: pxeboot.bs and vlan tagging
Message-ID:  <CAHzLAVH2ooLhK5JOrMxDD7ejDcDG=26VzOzqsmKrjrwA8MUf1g@mail.gmail.com>
In-Reply-To: <4F300391.2020002@locolomo.org>
References:  <CAHzLAVEKavBHqz4atdqys6KDJXqGpinCcEPg7--Nqn9ZZCTH4Q@mail.gmail.com> <4F2FF7D3.2030707@locolomo.org> <CAHzLAVHxpWyvcb-ioaEXOLkentujUbT6Fd7eEois4SHQa-MVAQ@mail.gmail.com> <CAHzLAVGYbbhyeCQCf6_KE=P_EuSFni2zOZb76XwFwYYC8-MpPw@mail.gmail.com> <4F300391.2020002@locolomo.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
We have determined that it has failed after loading pxeboot.bs and
before loading the kernel.  Therefore, the kernel is not the problem.
I have also determined that vlan tagging is not the problem as it has
failed with vlan tagging disabled.  I don't believe it is the content
because it works in 3 out of 4 different environments.  In fact, in
the 4th environment in recent tests, it worked a handful of times
before failing again.

Suspecting network configurations at this point, but thanks for the
input provided thus far.  It has been immensely helpful.

On Mon, Feb 6, 2012 at 11:45 AM, Erik N=F8rgaard <norgaard@locolomo.org> wr=
ote:
> On 06/02/2012 17:33, Rick Miller wrote:
>>>>
>>>> 2) do you fetch the kernel successfully?
>>>>
>>>> When using tftp, The kernel and kernel modules are fetched before the
>>>> memory
>>>> file system, so do pxeboot fetch the kernel but not the mfsroot?
>>>>
>>>> The reason for these questions is that your problem may be with the
>>>> kernel
>>>> and kernel modules and not pxeboot. Just to be sure.
>>>
>>>
>>> I see what you are saying. =A0We will have to look at the packet
>>> captures to make that determination.
>>
>>
>> The target system loads pxeboot.bs and consequently requests the
>> following files:
>>
>> /boot/boot.4th (which it does not find)
>> /boot/loader.rc
>> /boot/loader.4th
>> /boot/support.4th
>> /boot/defaults/loader.conf
>> /boot/device.hints
>> /boot/loader.conf
>>
>> It is at this point where the failure occurs. =A0The contents of loader.=
conf
>> are:
>>
>> mfsroot_load=3D"YES"
>> mfsroot_type=3D"mfs_root"
>> mfsroot_name=3D"/boot/mfsroot"
>>
>> Does this seem consistent with what you were theorizing that it's the
>> kernel that has the problem with vlan tagging and not pxeboot.bs?
>
>
> See the other mail, the way pxeboot works IIRC, is that first the pxeboot=
 is
> fetched using tftp, the pxeboot is given the next server and will fetch t=
he
> kernel, modules and other files from /boot/ on that server, (path respect=
ive
> to the root of the tftp dir).
>
> The kernel loads and will then fetch the mfsroot file. As mentioned, by
> default this is done using nfs, and nfs is assumed if the kernel supports
> nfs, even if it only fetches one file. This I understand has to be this w=
ay
> since the network configuration set with dhcp does not specify the protoc=
ol.
>
> So, if your kernel supports nfs it will not use tftp and hence fail.
>
> The details are somewhat distant to me, it's been some time since I messs=
ed
> arround with this.
>
> hope this helps.
>
> BR, Erik
> --
> M: +34 666 334 818
> T: +34 915 211 157



--=20
Take care
Rick Miller



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CAHzLAVH2ooLhK5JOrMxDD7ejDcDG=26VzOzqsmKrjrwA8MUf1g>