Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 1 Oct 2013 14:03:22 -0600
From:      "McConnell, Stephen" <Stephen.McConnell@lsi.com>
To:        "dgilbert@interlog.com" <dgilbert@interlog.com>, "Desai, Kashyap" <Kashyap.Desai@lsi.com>, Michael Fuckner <michael@fuckner.net>, FreeBSD-SCSI <freebsd-scsi@freebsd.org>
Subject:   RE: LSI 9300-4i4e support
Message-ID:  <A5E537D8E1B0EF499D49E9AE3E3458FE01B0C63AD4@cosmail03.lsi.com>
In-Reply-To: <524AE41D.2020807@interlog.com>
References:  <52473B95.2030705@interlog.com> <1450642901.368121.1380440131388.open-xchange@com4.strato.de> <52484D60.60105@interlog.com> <52486553.4020004@fuckner.net> <B2FD678A64EAAD45B089B123FDFC3ED76076822406@inbmail01.lsi.com> <524AE41D.2020807@interlog.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hi Doug, Thanks for the update.  As Kashyap noted, the issue with bunches o=
f messages has been fixed in our pre-GCA version.  The reason that we have =
not added the 9.1 driver version to our zip is that it needs to go through =
our testing procedure first.  It is scheduled to be released before the end=
 of the year.  9.2 will need to go through the same process and I don't kno=
w when that's going to be finalized yet.

As far as getting mpslsi3 upstream, I don't know exactly what's going to ha=
ppen at this point.  We (LSI) are trying to convince the FreeBSD community =
that the Gen2 and Gen3 drivers need to be separated and we're getting a lit=
tle understandable resistance.  LSI separated these drivers quite a while a=
nd it's unlikely that we'll merge Gen2 and Gen3 functionality back into one=
 driver.  So, we need come up with some solution.

Regards,
Steve McConnell

-----Original Message-----
From: Douglas Gilbert [mailto:dgilbert@interlog.com]=20
Sent: Tuesday, October 01, 2013 9:03 AM
To: Desai, Kashyap; Michael Fuckner; FreeBSD-SCSI
Cc: McConnell, Stephen
Subject: Re: LSI 9300-4i4e support

Yesterday I did an upgrade from 9.1 release to 9.2 release on a system with=
 a LSI 9300-4i4e in it and a SAS disk attached to the 4i4e holding the root=
fs. That worked albeit with the same CAM status error flood during each boo=
t.

So the mpslsi3 driver for 9.0 release provided by LSI works (with some nois=
e) for 9.1 release and 9.2 release.

Doug Gilbert


On 13-09-30 06:55 AM, Desai, Kashyap wrote:
> Michael:
>
> LSI 9300 card will work with <mpslsi3> driver which you have posted here =
from lsi's external site works for you.
>
> Prints which you have pointed for CAM status error are resolved in our la=
test driver, but still not posted to external site because we are waiting f=
or Internal driver GA.
>
> Regarding upstream submission of <mpslsi3> I have seen that Steve McConnn=
ell is working with Ken D Merry to get driver inbox.
>
> Added Steve M.. to give you more insight on mpslsi3 inbox.
>
> ` Kashyap
>
>> -----Original Message-----
>> From: owner-freebsd-scsi@freebsd.org [mailto:owner-freebsd-=20
>> scsi@freebsd.org] On Behalf Of Michael Fuckner
>> Sent: Sunday, September 29, 2013 11:07 PM
>> To: dgilbert@interlog.com; FreeBSD-SCSI
>> Subject: Re: LSI 9300-4i4e support
>>
>> Or even add support for 9.2 which will be released tomorrow.
>>
>> Regards,
>>    Michael!
>>
>> On 9/29/2013 5:55 PM, Douglas Gilbert wrote:
>>> The mpslsi3.ko modules provided by LSI in their support pages for=20
>>> the 9300-4i4e does work in 9.1 Release sufficiently well to bring up=20
>>> the system.
>>>
>>> There is no sensible report about it discovering this HBA in dmesg,=20
>>> just a thousand or so of these:
>>>     kernel: (probe1022:mpslsi30:0:1023:0): INQUIRY. CDB: 12 0 0 0 24 0
>>>     kernel: (probe1022:mpslsi30:0:1023:0): CAM status: Invalid=20
>>> Target
>> ID
>>>     kernel: (probe1022:mpslsi30:0:1023:0): Error 22, Unretryable=20
>>> error
>>>
>>> But it does get there in the end.
>>>
>>>
>>> LSI, if you are reading this, why not add 9.1 Release to your driver=20
>>> support zip file for the 9300 family?
>>>
>>> Doug Gilbert
>>>
>>> On 13-09-29 03:35 AM, Michael Fuckner wrote:
>>>> Hi,
>>>> did you try the driver provided by lsi? It seems to be for FreeBSD=20
>>>> 9.0, but perhaps it is also working.
>>>> http://www.lsi.com/products/storagecomponents/Pages/LSISAS9300-4i4e
>>>> .a
>>>> spx
>>>> ->
>>>> Support & Downloads -> Driver -> FreeBSD?
>>>> Seems like 12GBit is not supported inbox right now- I am still=20
>>>> waiting for my 12GBit HBA Card :( Regards,
>>>>    Michael!
>>>>
>>>>   > Douglas Gilbert <dgilbert@interlog.com> hat am 28. September=20
>>>> 2013 um 22:27 geschrieben:
>>>>   >
>>>>   >
>>>>   > I've noticed that 9.1 does not recognize a LSI 9300-4i4e  > SAS=20
>>>> HBA (relatively new: 12 Gbps). Do any more recent  > RCs or betas=20
>>>> have support for it?
>>>>   >
>>>>   > Doug Gilbert
>>>>   > _______________________________________________
>>>>   > freebsd-scsi@freebsd.org mailing list  >=20
>>>> http://lists.freebsd.org/mailman/listinfo/freebsd-scsi
>>>>   > To unsubscribe, send any mail to=20
>>>> "freebsd-scsi-unsubscribe@freebsd.org"
>>>
>>
>> _______________________________________________
>> freebsd-scsi@freebsd.org mailing list=20
>> http://lists.freebsd.org/mailman/listinfo/freebsd-scsi
>> To unsubscribe, send any mail to "freebsd-scsi-unsubscribe@freebsd.org"
>
>
>






Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?A5E537D8E1B0EF499D49E9AE3E3458FE01B0C63AD4>