Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 11 Nov 2014 18:17:39 -0200
From:      =?UTF-8?B?IkRhbnRlIEYuIEIuIENvbMOyIg==?= <dante01010@gmail.com>
To:        Jon Radel <jon@radel.com>, freeBSD <freebsd-questions@freebsd.org>
Subject:   Re: Static routing
Message-ID:  <54626EE3.2060308@gmail.com>
In-Reply-To: <545BEA8A.9070607@radel.com>
References:  <545BE713.9090705@gmail.com> <545BEA8A.9070607@radel.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hello Jon

I don't have so much experience with bridges, i'm not asking you to tell 
how to setup , i''ll take a look at   freebsd bridge related docs and 
something other stuff, but could you give me a brief of how would it 
work here ? . Thank you for your response.

Regards


  +-------+
  | Cisco |
  +-----+-+
        |if: 189.92.72.0/29
        |
        |em0: 189.92.72.10/255.255.255.248
      +-+-------+
      | FreeBSD |
      +-+-------+
        |em1: 189.92.72.11/255.255.255.248

        |
        |
  +-----+--+
  | Switch |            +-----------------+
  +--------+            |  MAIL           |
        |---------------+-----------------+
                         bnx0: 189.72.92.12/255.255.255.248



On 11/6/14 7:39 PM, Jon Radel wrote:
> On 11/6/14, 4:24 PM, "Dante F. B. Colò" wrote:
>> Hello everyone
>>
>> I'm trying to setup some static routes on a freebsd  box for some 
>> public addresses , the machine has two ethernet cards *em0 *and *em1 
>> ***, *em0* is attached to a Cisco internet router and *em1* is 
>> connected to a switch, both interfaces have  public addresses of the 
>> same range , *em1 *appears has absolutely no communication 
> It would be helpful if you provided the specific IP addresses you're 
> talking about, complete with the masks, and specific commands you 
> enter, or conf file lines you add or modify.  For starters, when you 
> talk about "both interfaces have  public addresses of the same range" 
> that's not a precise enough description for me to know if you mean two 
> addresses on the same subnet or two addresses, each in different 
> subnets (though they may be adjacent or part of the same larger 
> network).  If you do, in fact, mean two addresses in the same network, 
> then your IP topology is broken if you think you can do layer 3 
> routing between them, and the very first thing you'll need to do is 
> come up with a legal addressing scheme.  (Or consider layer 2 
> bridging, which has other design implications of its own but might 
> work better for you....)
>
>
>> ,  i took a look at the static routes and there is a route for the 
>> subnet that it goes to *em0* , i'm trying to add a static route for 
>> the ip address pointing to the***em1 *without pass gateway using 
>> *-iface* parameter but always returns "Network unreachble", 
> Something is confused, so it would be better to give us the output 
> you're looking at rather than your interpretation of that output.
>
> Not to say that somebody else may not be able to figure out precisely 
> what's going on based on this description, but I'm much more likely to 
> spot what's going wrong with specific information: actual configs; 
> actual output.
>
> --Jon Radel
> jon@radel.com
>




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?54626EE3.2060308>