Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 8 Dec 2013 18:31:36 +0100
From:      "Stefan Hegnauer" <stefan.hegnauer@gmx.ch>
To:        <freebsd-current@freebsd.org>
Subject:   nanobsd / dd problem?
Message-ID:  <000001cef43b$591c7c90$0b5575b0$@hegnauer@gmx.ch>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi,

 

I am using freebsd-current (FreeBSD BUILDMASTER 11.0-CURRENT FreeBSD
11.0-CURRENT #0 r259095: Sun Dec  8 10:20:40 CET 2013
root@BUILDMASTER:/usr/obj/usr/src/sys/ASUS  i386) in a VirtualBox as a build
machine for nanobsd images to be used on pc-engines.ch alix boards. The only
difference to GENERIC is the inclusion of 'march=geode' and disabling of
most debugging switches (malloc, Witness etc). Worked like a charm in the
past.

 

Since late summer - sorry, no exact date / svn revision - nanobsd.sh fails
at the last stage when building the disk image, e.g. with

...

00:00:25 ### log: /usr/obj/nanobsd.alixpf//_.di

#

 

Looking a bit closer it seems that dd(1) returns with an I/O error whenever
the input is a file created with mdconfig(8):

# dd if=/dev/zero of=somebackingfile bs=1k count=5k

# mdconfig -f somebackingfile -u md0

# newfs -U /dev/md0

# dd if=/dev/md0 of=/dev/null

dd: /dev/md0: Input/output error

10241+0 records in

10241+0 records out

5243392 bytes transferred in 3.240345 secs (1618159 bytes/sec)

 

The outputfile in nanobsd.sh seems to be error-free.

Anyone else seen similar behaviour? How to proceed/fix it?

 

Thanks

Stefan




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?000001cef43b$591c7c90$0b5575b0$>