Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 02 May 2013 17:52:27 +0400
From:      Andrey Chernov <ache@freebsd.org>
To:        Steven Hartland <killing@multiplay.co.uk>
Cc:        Alexander Motin <mav@FreeBSD.org>, current@FreeBSD.org, scsi@freebsd.org
Subject:   Re: Last current shows strange CAM/SCSI error on empty USB card reader on the boot
Message-ID:  <51826F9B.5030800@freebsd.org>
In-Reply-To: <C557BD160FC24442AE9A01BFF73908FF@multiplay.co.uk>
References:  <51820CE6.1050607@freebsd.org> <51821AE2.9010503@FreeBSD.org> <C557BD160FC24442AE9A01BFF73908FF@multiplay.co.uk>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 02.05.2013 15:33, Steven Hartland wrote:
> Yer, this one is slightly different issue than the one ken@ reported
> but its easy fixed, just needs:-
> Index: sys/cam/scsi/scsi_da.c
> ===================================================================
> --- sys/cam/scsi/scsi_da.c      (revision 250174)
> +++ sys/cam/scsi/scsi_da.c      (working copy)
> @@ -3118,7 +3183,7 @@
>                } else {
>                        int error;
>                        error = daerror(done_ccb, CAM_RETRY_SELTO,
> -                                       SF_RETRY_UA|SF_QUIET_IR);
> +                                       SF_RETRY_UA|SF_NO_PRINT);
>                        if (error == ERESTART)
>                                return;
> 

Thanx, this patch suppress console error.

-- 
bitcoin:13fGiNutKNHcVSsgtGQ7bQ5kgUKgEQHn7N



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?51826F9B.5030800>