Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 16 Dec 2006 20:40:37 -0600
From:      Lane <lane@joeandlane.com>
To:        freebsd-questions@freebsd.org
Cc:        "Michael P. Soulier" <msoulier@digitaltorque.ca>
Subject:   Re: upgrade of portupgrade fails
Message-ID:  <200612162040.37436.lane@joeandlane.com>
In-Reply-To: <20061217022424.GU16906@tigger.digitaltorque.ca>
References:  <20061217022424.GU16906@tigger.digitaltorque.ca>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Saturday 16 December 2006 20:24, Michael P. Soulier wrote:
> I did a portupgrade -R on sysutils/portupgrade, and it started upgrading
> ruby.
>
> Unfortunately, it failed.
>
> No definition for sock_s_unpack_sockaddr_un
>
>                          stringio.c:
> c.....................................................
>                           strscan.c:
> cc.............................................
>                              zlib.c:
> mcccccccccccccccccc........................................................
>........................... Generating RI...
> Killed
> *** Error code 137
>
> Stop in /usr/ports/lang/ruby18/work/ruby-1.8.5.
> *** Error code 1
>
> Stop in /usr/ports/lang/ruby18.
> *** Error code 1
>
> Stop in /usr/ports/lang/ruby18.
> ** Command failed [exit code 1]: /usr/bin/script -qa
> /tmp/portupgrade12405.0 make PORT_UPGRADE=yes reinstall
> egrep: /var/db/pkg/ruby-1.8.4_9,1/+CONTENTS: No such file or directory
> --->  Restoring the old version
>
> Any ideas why?
>
> Thanks,
> Mike
I had this problem as well after going from 6.1 to -CURRENT

I "fixed" it by doing

cd /usr/ports/lang/ruby18
make -DFORCE_PKG_REGISTER install

and then rebuilt sysutils/portupgrade

lane



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200612162040.37436.lane>