Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 10 Apr 2012 08:13:36 +1000
From:      Da Rock <freebsd-questions@herveybayaustralia.com.au>
To:        freebsd-questions@freebsd.org
Subject:   Re: zpool creation on geli failed with FreeBSD-9.0
Message-ID:  <4F835F10.4000207@herveybayaustralia.com.au>
In-Reply-To: <20120409180730.08dfe9bb@dijkstra.cruwe.de>
References:  <20120409180730.08dfe9bb@dijkstra.cruwe.de>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 04/10/12 02:07, Christopher J. Ruwe wrote:
> I was trying to install FreeBSD 9.0 using a geli encrypted disk and
> ZFS on my ThinkPad R500 this weekend. I failed.
>
> Having sucessfully initialized the geli part and having attached the
> provider, my attempt to create a zpool on the geli section thus
>
> $>  zpool create ntank /dev/ada0p2.eli
>
> failed with the message
>
> Cannot create 'ntank': invalid argument for this pool operation.
>
> I could not convince the system to create the zpool on the geli part, so
> I gave up and created the zpool on the unencrypted partition instead to
> have a working machine for the week. I would, however, like to have my
> data on an encrypted partition though. Has anyone witnessed and resolved
> this issue or does anyone have other ideas?

Someone using ZFS will be able to verify this, but from my understanding 
ZFS runs on the hardware and you can *possibly* put geli on top of ZFS.

You can put geom on ZFS but not the other way around.

HTH



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4F835F10.4000207>