Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 15 Sep 2017 20:03:15 +0200
From:      Polytropon <freebsd@edvax.de>
To:        Ian Smith <smithi@nimnet.asn.au>
Cc:        Warren Block <wblock@wonkity.com>, "Steve O'Hara-Smith" <steve@sohara.org>, freebsd-questions@freebsd.org
Subject:   Re: Restoring sc console look and feel with vt
Message-ID:  <20170915200315.289b3fdf.freebsd@edvax.de>
In-Reply-To: <20170916020243.B81507@sola.nimnet.asn.au>
References:  <mailman.83.1505476802.36054.freebsd-questions@freebsd.org> <20170916020243.B81507@sola.nimnet.asn.au>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sat, 16 Sep 2017 02:37:15 +1000 (EST), Ian Smith wrote:
> In freebsd-questions Digest, Vol 693, Issue 5, Message: 1
> On Thu, 14 Sep 2017 07:41:19 -0600 (MDT)
> Warren Block <wblock@wonkity.com> wrote:
>  > On Sat, 9 Sep 2017, Steve O'Hara-Smith wrote:
>  > 
>  > > On Sat, 9 Sep 2017 07:49:32 -0600 (MDT)
>  > > Warren Block <wblock@wonkity.com> wrote:
>  > >
>  > >> On Sat, 9 Sep 2017, Polytropon wrote:
>  > >>
>  > >>> My 10.3 loader doesn't seem to know that command. Do I need to
>  > >>> upgrade to 11?
>  > >>
>  > >> I think that's correct.  There are a bunch of technologies involved,
>  > >> including kernel mode switching (video drivers) and possibly UEFI, and
>  > >> the gop command might only have appeared recently.  Somebody(TM) ought
>  > >> to try to get a comprehensive overview of how it all ties together and
>  > >> write an article.
>  > >
>  > > 	I'm not seeing a gop command on my 11.1 box.
>  > 
>  > It's a loader command.
> 
> And as far as I can tell, entirely undocumented - though looking at the 
> commit messages for the file mentioned below might be helpful; I gave up 
> before trying.  As mentioned, I'd grep'd source of mans for loader.conf 
> and pretty much everything else to do with booting and loader; not to 
> say I didn't miss something obvious to someone who actually knows this.
> 
> Sorry about breaking threading by (albeit carefully) replying to the
> digests, but to not waste the quite some time put into hunting this:
> 
> https://lists.freebsd.org/pipermail/freebsd-questions/2017-September/278783.html
> 
> That is, check /usr/src/sys/boot/efi/loader/arch/amd64/framebuffer.c
> 
> So if this file appears in 11.1 - or 10.3? - then maybe somebody can 
> figure out what parameters might be fed to gop(0) and to what effect; 
> reading the whole code sort-of seems to offer some sort-of clues ..

So it's not a surprise that my particular testing installation
does not have a "gop" command in the loader. I'm using FreeBSD
10.3 (patched) i386 on a machine with BIOS (not UEFI).





-- 
Polytropon
Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20170915200315.289b3fdf.freebsd>