Skip site navigation (1)Skip section navigation (2)
Date:      9 Apr 2012 23:25:19 -0000
From:      Scott Ballantyne <sdb@ssr.com>
To:        freebsd-questions@freebsd.org
Subject:   Difficulties accessing optical drive from guest OS in VBox
Message-ID:  <20120409232519.2343.qmail@irelay.ssr.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi,

Not sure if this should be here orin freebsd-emulation, but thought it
worth a try:

Freebsd 9.0-RELEASE (GENERIC)
VBoxMange --version:  4.1.10_OSEr76795
Installed from Ports.
Window 7 as guest.


I can't access the host optical drive from the guest OS. I was able to
install it by dd'ing the install DVD to the harddrive, and VBox used
that beautifully.

It all works quite well, but whenever I try to use the actual optical
drive, I get a 'permissions error':

"Unable to mount the CD/DVD Host Drive HL-DT-STDVDRAM GH24LS50 DVDRAM
GH24LS50 (cd0) on the machjine Windows_7_64bit. Would you like to
force mounting of this medium?"

"Could not mount the media/drive '/dev/cd0'"

And the Details:

"Interface: 
IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}
Callee: 
IMachine {5eaa9319-62fc-4b0a-843c-0cb1940f8a91}"

Incidentally, inspite of the message, there is no "force mount" option
given, only 'cancel'  and  'force unmount'.

I've followed the handbook and Wiki for the DVD/CD access, I'm in the
operator group, atapicam is loaded, hald is enabled and running and
the permissions for cd0, xpt0 and pass0 are all 0660.

I've also tried adding CD0 in the graphical interface before I start
the VM. Bizarrely, this caused VBox to try to boot from the DVD (even
though that is unchecked in the boot options).

The only other thing I've tried is to disable the automounting of
media with Gnome, in case that was interfering. No luck.

So, anyone have any ideas?  They would be most appreciated.

Thanks for your time,
Scott
-- 
sdb@ssr.com




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20120409232519.2343.qmail>