Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 01 Sep 2013 22:48:44 -0600
From:      Gary Aitken <vagabond@blackfoot.net>
To:        "illoai@gmail.com" <illoai@gmail.com>
Cc:        FreeBSD Mailing List <freebsd-questions@freebsd.org>
Subject:   Re: trouble building lsof?
Message-ID:  <522418AC.2020903@blackfoot.net>
In-Reply-To: <CAHHBGkrkqE30m-HF8L2G7+dZhPyvibz7XkRU9hCZA=DsTM7pow@mail.gmail.com>
References:  <5223DDA3.6020908@blackfoot.net> <CAHHBGkrxQwfG2fxOsoGfsjTfshgH9V_TLvDe04EKz6K-1x9nbg@mail.gmail.com> <CAHHBGkrkqE30m-HF8L2G7+dZhPyvibz7XkRU9hCZA=DsTM7pow@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 09/01/13 20:34, illoai@gmail.com wrote:
> On 1 September 2013 22:32, illoai@gmail.com <illoai@gmail.com> wrote:
>> On 1 September 2013 20:36, Gary Aitken <vagabond@blackfoot.net> wrote:
>>> portsnap and update just done,
>>> UPDATING shows nothing,
>>> /etc/make.conf contains
>>>   WITH_PKGNG=yes
>>
>> I don't know, but I have it set to use gcc46 & it builds fine.
>>
>> Do you perhaps have
>> WITH_CLANG_IS_CC=
>> set?
>>
> 
> Check that.
> 
> It builds fine with clang on 9.2-RC3.

strange.

#make build-depends-list
/usr/ports/ports-mgmt/pkg

there are no dependencies other than bare system ones,
so it's doubly strange.

It's complaining that
  ThreadRuneLocale
is undefined.
It's referenced in /usr/include/runetype.h,
but not defined in any of /usr/include/*.h or /usr/include/sys/*.h
Can someone tell me where it's supposed to be defined?




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?522418AC.2020903>