Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 23 Aug 2011 23:30:35 +0100
From:      Chris Rees <utisoft@gmail.com>
To:        "Morse, Richard E.MGH" <REMORSE@partners.org>
Cc:        "freebsd-questions@freebsd.org" <freebsd-questions@freebsd.org>
Subject:   Re: How to allow Amanda to install as operator?
Message-ID:  <CADLo839wcWCSJK+jmszsc2mtUgKW75UCjdMqGays588tUtrxzw@mail.gmail.com>
In-Reply-To: <4169877D-ADC9-4647-AFBE-78C409156EDF@partners.org>
References:  <CADLo83-kBX5ie-ayD-7-CF+eZDKU1O2zGXo4cFHTfA8ctmQ9yg@mail.gmail.com> <4169877D-ADC9-4647-AFBE-78C409156EDF@partners.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 23 Aug 2011 21:42, "Morse, Richard E.MGH" <REMORSE@partners.org> wrote:
>
> On Aug 23, 2011, at 4:01 PM, Chris Rees wrote:
>
> > "Morse, Richard E.MGH" wrote:
> >>       GID_FILES="/usr/ports/OP_GROUP" UID_FILES="/usr/ports/OP_USER"
> >> AMANDA_USER="operator" AMANDA_GROUP="operator" make install
> >>
> >> This runs along for a while, then dies with the note:
> >>
> >>       ** /usr/ports/OP_GROUP doesn't exist. Exiting.
> >>       *** Error code 1
> >>
> >>
> >> If I do a `less /usr/ports/OP_GROUP` (copying exactly from the error
> >> message), I can see the file I created just fine.
> >>
> >> Is there something that I'm missing? How am I supposed to install a
port as
> >> a user that already exists? Why doesn't make see that the file exists?
> >>
> >
> > Update your ports tree and try again. Let me know if it doesn't work!
> >
> > http://lists.freebsd.org/pipermail/cvs-ports/2011-August/224032.html
>
> Thanks! This change made the install happen OK.
>
> I am still wondering if there was something I should have done to make
overriding GID_FILES and UID_FILES work?
>

Lose the quotes ;)

Chris



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CADLo839wcWCSJK+jmszsc2mtUgKW75UCjdMqGays588tUtrxzw>