Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 23 Mar 2009 21:29:53 +0100
From:      Polytropon <freebsd@edvax.de>
To:        Christoph Kukulies <kuku@kukulies.org>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: libxml-2-7-3 (php5 pkg_add)
Message-ID:  <20090323212953.715aaa44.freebsd@edvax.de>
In-Reply-To: <49C7BFF7.9030101@kukulies.org>
References:  <49C7BFF7.9030101@kukulies.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Mon, 23 Mar 2009 17:59:35 +0100, Christoph Kukulies <kuku@kukulies.org> wrote:
> I wanted to do a
> 
> pkg_add -r php5
> 
> under 7.1 Beta1 and got a warning:
> 
> pkg_add: warning: package 'php5-5.2.8' requires 'libxml2-2.7.3', but 
> 'libxml2-2.6.32' is installed
> 
> 
> Should I care [...]

Run your PHP and see if it refuses to work, or if you encounter
any problems while running. 2.6.32 and 2.7.3 may be a version gap
that leads to nonfunctionality.



> [...] and if, how do I "repair" this?

You could update your libxms2 port to get it to a newer version.
If you're using portupgrade (portinstall), use

	# pkgdb -aF

to fix package dependencies.


-- 
Polytropon
>From Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20090323212953.715aaa44.freebsd>