Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 7 Nov 2012 02:56:32 -0800 (PST)
From:      Jack Mc Lauren <jack.mclauren@yahoo.com>
To:        FreeBSD Global Users Mailing List <freebsd-questions@freebsd.org>
Subject:   nanobsd boot problem
Message-ID:  <1352285792.16601.YahooMailNeo@web126004.mail.ne1.yahoo.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi all=0AI have some problems in the second phase of running a=0Adevice fro=
m a nanobsd image.=A0=0AAfter copying the image on a flash memory, and afte=
r I set=0Athe system to boot up from flash memory, I just see a black scree=
n and a=0Ablinking cursor ! looks like the boot device ( flash memory ) is =
not recognized=0Aby the system.=0AHere are my debugging information , if th=
ey are not enough,=0Atell me please to send you necessary informations :=0A=
dmesg output :=0Ada0 at umass-sim0 bus 0 scbus0=0Atarget 0 lun 0=0Ada0: <UF=
D 2.0 Silicon-Power8G=0APMAP> Removable Direct Access SCSI-4 device=0Ada0: =
40.000MB/s transfers=0Ada0: 7388MB (15130624 512 byte=0Asectors: 255H 63S/T=
 941C) =A0=A0=0Aaccording to the last line, I change the NANO_SECTS to 63=
=0Aand NANO_HEADS to 255. (in=A0nanobsd.sh).=0Als /dev output :=0A=A0=A0=A0=
=A0=A0=A0=A0=A0=A0=A0 da0s1=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 da0s1a=A0=A0=A0=
=A0 ad6s1b=A0=A0=A0=A0=A0=A0=A0=A0=A0 da0s3=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 a=
d6s1d=A0=A0=A0=A0=A0=A0=A0=A0=A0 da0s4=0Aaccording to the first column , I =
set NANO_DRIVE to da0. (in=0Ananobsd.sh)=0Aand here are the contents of the=
 flash memory :=0A=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 ls /mnt=0A.=
cshrc=A0=A0=A0=A0=A0=A0=A0=A0=A0 boot=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 lib=
=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 rescue=A0=A0=A0=A0=A0=A0=A0=A0=A0 usr=
=0A.profile=A0=A0=A0=A0=A0=A0=A0 cfg=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 li=
bexec=A0=A0=A0=A0=A0=A0=A0=A0 root=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 var=0A.=
snap=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 conf=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 me=
dia=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 sbin=0ACOPYRIGHT=A0=A0 =A0=A0=A0=A0dev=A0=
=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 mnt=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 s=
ys=0Abin=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 etc=A0=A0=A0=A0=A0=A0=A0=A0=A0=
=A0=A0=A0 proc=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 tmp=0AAm I missing somethin=
g ?? could you please me please ?=A0=0A
From owner-freebsd-questions@FreeBSD.ORG  Wed Nov  7 12:37:22 2012
Return-Path: <owner-freebsd-questions@FreeBSD.ORG>
Delivered-To: freebsd-questions@freebsd.org
Received: from mx1.freebsd.org (mx1.freebsd.org [69.147.83.52])
 by hub.freebsd.org (Postfix) with ESMTP id 4A162195;
 Wed,  7 Nov 2012 12:37:22 +0000 (UTC) (envelope-from fidaj@ukr.net)
Received: from fsm2.ukr.net (fsm2.ukr.net [195.214.192.121])
 by mx1.freebsd.org (Postfix) with ESMTP id DED3B8FC20;
 Wed,  7 Nov 2012 12:37:21 +0000 (UTC)
DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=ukr.net;
 s=fsm; 
 h=Content-Transfer-Encoding:Content-Type:Mime-Version:Message-ID:Subject:Cc:To:From:Date;
 bh=16SIy1wCVlY+GVcFPsGSkF8aDjgnlcH9JvQ0Hq5kZHg=; 
 b=PAvNiDA6NXvEPgg90FgDB0eC292swuP+agh9gWgu8tG0qd05Jq6J7CZGuOYGpNsVhshya8H2SNmnwrlnGd0KLjlmhY5zvH+QMvuuPWo/1KotlZlg20mY4Q52HFfzfgIiRL1XwxfxYTMwaknq9D8fVUT22sC2pBbzFFsCK+8440o=;
Received: from [178.137.138.140] (helo=nonamehost)
 by fsm2.ukr.net with esmtpsa ID 1TW4sb-000Aum-Oj
 ; Wed, 07 Nov 2012 14:37:13 +0200
Date: Wed, 7 Nov 2012 14:37:10 +0200
From: Ivan Klymenko <fidaj@ukr.net>
To: freebsd-questions@freebsd.org, freebsd-mips@freebsd.org
Subject: Errors cross compilation of architecture MIPS
Message-ID: <20121107143710.3326e801@nonamehost>
X-Mailer: Claws Mail 3.8.0 (GTK+ 2.24.10; x86_64-pc-linux-gnu)
Face: iVBORw0KGgoAAAANSUhEUgAAADAAAAAwBAMAAAClLOS0AAAAFVBMVEWpqak/Pz/i4uIfHx8GBwZwcHAQEBA6o92AAAACHElEQVQ4jWWUTY7bMAyF6QzUPSEoa8PFHEBgqwuM4bVVg7MvZOj+R+ijpMTpjIwgkT7z75EKrdfattpXERG6zqvUOtAr2LCRYfEKcB4l/Q+2cc6XjQH7hv+2YZYreIk5nevZEPvuzUzptizHLzgDMnC5Wpbl7ewJlOEqlQF+DlCjgVLki0WV6FMDMsBxjlJiQulIznwZ+DxHiQyDyIg0wN3Oo6o6ZQ5s5AIfar+W2Wlmz+kCcb8tg6j3voMEwNrBQk69dDBDqw/urpqJH+m+Q6u/4QnoAeYpnUXC/s1iup9rhCd6xMgAqdDyAyFegbKkVAHeLCcOulPLawaoUIDos4M88iLNrVkU7uu5ccTDO6naJzWLum51C6Yb7y4HKKbdArLWir0PBiS8glJRBZHeyHl7J9lENpAC6qT9NlNG4u5hsVYDyJP6mlJJtY3oVju4WSUzHal1sDU17NASoBWSk40J2eBLBJhYrVmzC5gVALGpNIAiQgN6eGstOp9Oa6zFbbLTISYi28BGZDRUJKWeroECkCEkzXjUtbmmaKMfAx2RfbT69/cO+tgHcmx6AfyZOmj3NDIah0F0GB66d4CrdIoplNFFGHSpSheRxbo0W4S8azNItEoMWbw3uXAeJgCrmX5joz7CGXqSg6PcryEhnFr/C1C2ntPxBOYbdwY+8dO3+wZJyFlbMX9s8zNnvp/tLwAv03NB4j3HVpn8Awwm+GrlP6MVAAAAAElFTkSuQmCC
Mime-Version: 1.0
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: 7bit
Cc: jmallett@FreeBSD.org
X-BeenThere: freebsd-questions@freebsd.org
X-Mailman-Version: 2.1.14
Precedence: list
List-Id: User questions <freebsd-questions.freebsd.org>
List-Unsubscribe: <http://lists.freebsd.org/mailman/options/freebsd-questions>, 
 <mailto:freebsd-questions-request@freebsd.org?subject=unsubscribe>
List-Archive: <http://lists.freebsd.org/pipermail/freebsd-questions>;
List-Post: <mailto:freebsd-questions@freebsd.org>
List-Help: <mailto:freebsd-questions-request@freebsd.org?subject=help>
List-Subscribe: <http://lists.freebsd.org/mailman/listinfo/freebsd-questions>, 
 <mailto:freebsd-questions-request@freebsd.org?subject=subscribe>
X-List-Received-Date: Wed, 07 Nov 2012 12:37:22 -0000

Hi all.

I have uname -rms
FreeBSD 10.0-CURRENT amd64

I use to build system for architecture MIPS the instructions on the wiki
http://wiki.freebsd.org/FreeBSD/mips

I use next script build.sh http://privatepaste.com/339d25c604
but the compilation fails http://privatepaste.com/106d4015d0

then I add the option -DWITHOUT_GROFF \ in build.sh
and re-run the script build.sh

Next, I get the following error http://privatepaste.com/9887e06e42

then I add the option -DWITHOUT_SENDMAIL \ in build.sh
and re-run the script build.sh

Next, I get the following error http://privatepaste.com/962b406024

In what could be the problem here and what I'm doing wrong?

Thanks.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?1352285792.16601.YahooMailNeo>