Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 16 Sep 2017 08:03:43 -0500
From:      Adam Vande More <amvandemore@gmail.com>
To:        Scott Ballantyne <sdb@ssr.com>
Cc:        FreeBSD Questions <freebsd-questions@freebsd.org>
Subject:   Re: Curious pkg upgrade behavior
Message-ID:  <CA+tpaK0_Ev+7su-Hiu4jnCF1ec2sHknkzudTQ_+bcFvQj_tnpw@mail.gmail.com>
In-Reply-To: <20170916121755.1297.qmail@irelay.ssr.com>
References:  <20170916121755.1297.qmail@irelay.ssr.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sat, Sep 16, 2017 at 7:17 AM, Scott Ballantyne <sdb@ssr.com> wrote:

> On a 10.3-RELEASE-p11 system here. I have been moving to pkg for
> upgrades, and today tried a pkg upgrade, which upgraded several of the
> ports. After this, Samba failed with an internal error. I'm running
> Samba4, but this specific error seems to have been reported only with
> versions of Samba36.
>
> After much head scratching, I noticed that pkg had actually not
> upgraded Samba. So I tried running pkg upgrade again, which now
> dutifully upgraded Samba and solved my problem.
>
> I was surprised by this. Not sure if this was my problem, a bug in
> pkg, or just some mysterious phase of the moon situation.
>
> I would have thought pkg could have issued a message if it needed to
> be run again?
>
> Any insight?
>

/var/log/messages will contain a log of what pkg did, but net/samba4x is
not an upgrade to net/samba36 in terms of pkg's.

-- 
Adam



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CA+tpaK0_Ev+7su-Hiu4jnCF1ec2sHknkzudTQ_+bcFvQj_tnpw>