Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 28 Feb 2012 10:21:42 -0500 (EST)
From:      Randy Schultz <schulra@earlham.edu>
To:        freebsd-questions@freebsd.org
Subject:   zpool not grabbing hot spare
Message-ID:  <alpine.BSF.2.00.1202281021000.90975@tdream.lly.earlham.edu>

Next in thread | Raw E-Mail | Index | Archive | Help
Howdy howdy,

Got a zpool that lost a drive:
    Feb 24 20:46:01 booto kernel: (da30:mpt3:0:6:0): lost device
    Feb 24 20:46:41 booto kernel: (da30:mpt3:0:6:0): Synchronize cache failed, status == 0xa, scsi status ==
    0x0
    Feb 24 20:46:41 booto kernel: (da30:mpt3:0:6:0): removing device entry

however the spare never came online:
       zpool status -v
      pool: data
     state: DEGRADED
    status: One or more devices has been removed by the administrator.
            Sufficient replicas exist for the pool to continue functioning in a
            degraded state.
    action: Online the device using 'zpool online' or replace the device with
            'zpool replace'.
     scan: resilvered 0 in 0h2m with 0 errors on Tue Oct 25 13:40:59 2011
    config:

            NAME        STATE     READ WRITE CKSUM
            data        DEGRADED     0     0     0
              raidz2-0  DEGRADED     0     0     0
                da2     ONLINE       0     0     0
                da3     ONLINE       0     0     0
                da4     ONLINE       0     0     0
                da5     ONLINE       0     0     0
                da6     ONLINE       0     0     0
                da7     ONLINE       0     0     0
                da9     ONLINE       0     0     0
                da10    ONLINE       0     0     0
                da11    ONLINE       0     0     0
                da12    ONLINE       0     0     0
                da13    ONLINE       0     0     0
                da14    ONLINE       0     0     0
                da15    ONLINE       0     0     0
                da17    ONLINE       0     0     0
                da18    ONLINE       0     0     0
                da19    ONLINE       0     0     0
                da20    ONLINE       0     0     0
                da21    ONLINE       0     0     0
                da22    ONLINE       0     0     0
                da23    ONLINE       0     0     0
                da25    ONLINE       0     0     0
                da26    ONLINE       0     0     0
                da27    ONLINE       0     0     0
                da28    ONLINE       0     0     0
                da29    ONLINE       0     0     0
                da30    REMOVED      0     0     0
                da31    ONLINE       0     0     0
                da32    ONLINE       0     0     0
                da33    ONLINE       0     0     0
                da34    ONLINE       0     0     0
                da35    ONLINE       0     0     0
                da36    ONLINE       0     0     0
                da37    ONLINE       0     0     0
                da38    ONLINE       0     0     0
                da39    ONLINE       0     0     0
                da40    ONLINE       0     0     0
                da41    ONLINE       0     0     0
                da42    ONLINE       0     0     0
                da43    ONLINE       0     0     0
                da44    ONLINE       0     0     0
                da45    ONLINE       0     0     0
                da46    ONLINE       0     0     0
                da47    ONLINE       0     0     0
            logs
              mirror-1  ONLINE       0     0     0
                da24    ONLINE       0     0     0
                da16    ONLINE       0     0     0
            spares
              da1       AVAIL

I thought the spare was supposed to come online and be resilvered automatically.  Did I miss some config thing
or did I just misunderstand how the hot spare bit works?

--
  Randy    (schulra@earlham.edu)      765.983.1283         <*>

nosce te ipsum




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.BSF.2.00.1202281021000.90975>