Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 12 Dec 2015 23:23:10 -0553.75
From:      "William A. Mahaffey III" <wam@hiwaay.net>
To:        freebsd-x11@freebsd.org, freebsd questions list <freebsd-questions@freebsd.org>
Subject:   Re: problems running OpenGL code
Message-ID:  <566CFF74.6000402@hiwaay.net>
In-Reply-To: <566CA20C.4050307@b1t.name>
References:  <566C3DAD.8090809@hiwaay.net> <20151212173509.fba928df.freebsd@edvax.de> <566C51CB.8040604@hiwaay.net> <566C536F.8080507@hiwaay.net> <566C5966.8020403@hiwaay.net> <566C75F3.1090801@b1t.name> <566C94A6.1090703@hiwaay.net> <566CA20C.4050307@b1t.name>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 12/12/15 16:45, Volodymyr Kostyrko wrote:
> On 12.12.2015 23:40, William A. Mahaffey III wrote:
>> xorg.conf was/is still using the VESA driver, do I need any changes
>> there as well ?
>
> yep
>
>> Section "Files"
>>          ModulePath   "/usr/local/lib/xorg/modules"
>>          FontPath     "/usr/local/lib/X11/fonts/misc/"
>>          FontPath     "/usr/local/lib/X11/fonts/TTF/"
>>          FontPath     "/usr/local/lib/X11/fonts/OTF"
>>          FontPath     "/usr/local/lib/X11/fonts/Type1/"
>>          FontPath     "/usr/local/lib/X11/fonts/100dpi/"
>>          FontPath     "/usr/local/lib/X11/fonts/75dpi/"
>> EndSection
>
> This one is not needed mostly, you are specifying defaults.
>
>> Section "Module"
>>          Load  "dbe"
>>          Load  "dri"
>>          Load  "dri2"
>>          Load  "extmod"
>>          Load  "record"
>>          Load  "glx"
>> EndSection
>
> Same here, server will try to load them anyway.
>
>> Section "InputDevice"
>>          Identifier  "Mouse0"
>>          Driver      "mouse"
>>          Option      "Protocol" "auto"
>>          Option      "Device" "/dev/sysmouse"
>>          Option      "ZAxisMapping" "4 5 6 7"
>> EndSection
>>
>> Section "InputDevice"
>>          Identifier "Mouse0"
>>          Driver "vboxmouse"
>> EndSection
>
> You have two definitions for mouse, make `Identifier` different or... 
> actually I don't know which one would be selected.
>
>> Section "Device"
>>          ### Available Driver options are:-
>>          ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
>>          ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
>>          ### [arg]: arg optional
>>          #Option     "ShadowFB"                  # [<bool>]
>>          #Option     "DefaultRefresh"            # [<bool>]
>>          #Option     "ModeSetClearScreen"        # [<bool>]
>>          Identifier  "Card0"
>>          Driver      "vesa"
>>          VendorName  "Advanced Micro Devices, Inc. [AMD/ATI]"
>>          BoardName   "Kabini [Radeon HD 8280 / R3 Series]"
>>          BusID       "PCI:0:1:0"
>> EndSection
>>
>> Section "Device"
>>          ### Available Driver options are:-
>>          ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
>>          ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
>>          ### [arg]: arg optional
>>          Identifier "Card0"
>>          Driver "vboxvideo"
>>          VendorName "InnoTek Systemberatung GmbH"
>>          BoardName "VirtualBox Graphics Adapter"
>>          BusID "PCI:0:2:0"
>> EndSection
>
> Same here, you are defining one `Identifier` twice.

Found this online somewhere, pursuant to (trying to) get vbox running, 
still dicey .... Ditto the above twice-Identified Mouse0 ....

>
> And yes, here you need to specify your driver. Mine looks like:
>
> Section "Device"
>   Identifier "Integrated"
>   Driver "ati"
> EndSection
>
> My config also has this:
>
> Section "ServerFlags"
>   Option "AIGLX" "True"
>   Option "BlankTime" "0"
>   Option "StandByTime" "0"
>   Option "SuspendTime" "0"
>   Option "OffTime" "10"
>   Option "AutoAddDevices" "False"
>   Option "AllowEmptyInput" "False"
>   Option "Log" "Sync"
>   Option "DRI2" "On"
> EndSection
>
> Section "DRI"
>   Mode 0666
> EndSection
>
> Section "Extensions"
>   Option "Composite" "On"
>   Option "RENDER" "on"
>   Option "DAMAGE" "on"
> EndSection
>
> I'm not saying you need to put all of that in your config, I haven't 
> tested whether all of that is still needed today. You know, time 
> passes by and you have no time to fix those thing since everything is 
> still working fine. For example I think whole `Extensions` section 
> became useless...
>
> PS: Thanks man, made me review my own config so I'll go testing now. :)


No problema, happy to oblige. Let me know what you find ;-) .... I think 
I am supposed to be radeon, but not sure. Is your hardware AMD APU gfx ?


-- 

	William A. Mahaffey III

  ----------------------------------------------------------------------

	"The M1 Garand is without doubt the finest implement of war
	 ever devised by man."
                            -- Gen. George S. Patton Jr.




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?566CFF74.6000402>