Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 17 Sep 2017 02:21:51 +1000 (EST)
From:      Ian Smith <smithi@nimnet.asn.au>
To:        Polytropon <freebsd@edvax.de>
Cc:        Warren Block <wblock@wonkity.com>, "Steve O'Hara-Smith" <steve@sohara.org>, freebsd-questions@freebsd.org
Subject:   Re: Restoring sc console look and feel with vt
Message-ID:  <20170917011446.F81507@sola.nimnet.asn.au>
In-Reply-To: <20170915200315.289b3fdf.freebsd@edvax.de>
References:  <mailman.83.1505476802.36054.freebsd-questions@freebsd.org> <20170916020243.B81507@sola.nimnet.asn.au> <20170915200315.289b3fdf.freebsd@edvax.de>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Fri, 15 Sep 2017 20:03:15 +0200, Polytropon wrote:
 > On Sat, 16 Sep 2017 02:37:15 +1000 (EST), Ian Smith wrote:
[..]

 > > That is, check /usr/src/sys/boot/efi/loader/arch/amd64/framebuffer.c

 > So it's not a surprise that my particular testing installation
 > does not have a "gop" command in the loader. I'm using FreeBSD
 > 10.3 (patched) i386 on a machine with BIOS (not UEFI).

Yeah, sorry.  I see now that your first message in this thread said:

 > Experimental system is FreeBSD/i386 10.3-p22 (held current with
 > freebsd-update).

but not again till now, so it had slipped my mind (easily done :)

I've since checked that 11.1 won't help you in this respect either.

Are you sure there's no way to use sc(4) with X on 10.3?  We saw lots 
about getting proper console switching going (again) using vt and X on 
the stable@ list on earlier 10.x, but I can't recall any details, since 
sc still works fine on my 9.3 (amd64) system, where vt(4) first became 
available, including proper suspend/resume support from ttyvN or from X.

But that's using a much older X (and everything else), so I wouldn't 
want to lend you any false hope at this stage ..

cheers, Ian



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20170917011446.F81507>